Someone is using Ubuntu Studio with OpenFramework?

Someone is using Ubuntu Studio with OpenFramework?
I make this question because I have this problem: I have a Focusrite Pro 24 with firewire connection. must have drivers FFado to use this card. It is easy to configure Ffado jacks together. Recommend that you have installed Ubuntu Study: better kernel, and updated drivers. I can upgrade from Ubuntu 11.04 to UbuntuStudio but I would not been matched by compatibility issues.
When the mixer ffado reads my Focusrite but I could still hear no sound … (maybe I better set the panel, I have not fully understood all).
Since I use my card for audio openframework several projects, I wanted to have this feedback from the community of OF.
thanks.

i have installed UbuntuSudio 11.04. i had an issue like this: [http://forum.openframeworks.cc/t/undefined-reference-to---glewactivetexture'-of-007/7294/0](http://forum.openframeworks.cc/t/undefined-reference-to-–glewactivetexture’-of-007/7294/0) because UbuntuSudio install libjack2 , instead OpenFramework need libjack. after installing this i have no problems with the compilation of the examples.instead running the image loaderExample i received this error:

Xlib: extension “GLX” missing on display “:0.0”.
freeglut (openframeworks): OpenGL GLX extension not supported by display ‘:0.0’

i have run the script install_dependencies.sh and i have freeglut…i’ve checked it…
after reinstalling Nvidia driver,the problem disappeared.

. I have not yet understand how ffado mixer works and how i must setup audacity to works with my focusrite … but this is another story… but why we should use libjack2 in OF?

it’s a dependency to portaudio

i changed my laptop to dell inspiron n5110 i m getting the same error(the os is ubuntu 11.10)
earlier i was using ubuntu 11.10 in hp pavillin dv2000 i didnt get any error
i even removed and reinstalled the nvdia acclerated driver please help

i have Nvidia driver 270.41.19 (driver suggested to work with Cuda sdk 4.0) what driver and what graphic card?
as i said after reinstalling the driver the problem disappear.

I am using Ubuntu Studio (11.10) and I believe that the problem you are describing can be solved by:

a) Totally removing PulseAudio (seriously, its not worth keeping)
b) Setting up an ALSA <-> Jack loop, as described here:

http://alsa.opensrc.org/Jack-and-Loopback-device-as-Alsa-to-Jack-bridge

This works perfectly and is absolutely a breeze … I just boot my workstation, start up Jack with qjackctl, and from that point on all ALSA-only apps can use my audio interface (Presonus FirePod 10, a firewire interface) …

Good luck!