Some inconsistent problems with shaders [SOLVED]

Working on an ink bleed effect in glsl, trying to get it to work in oF now. It appears that the functionality is there, the calculations look right and everything. My problem seems to be in two places.

  1. When the file size of the incoming jpg is small, 40kb, the texture works, but not with the uniform float representing time. I have to swap out the uniform for a hard coded float, at which point it appears like it might be working, just frozen at that step in time.

  2. When the file is saved as a .bmp with 32 bit depth, it displays when passed straight through the shader, but not when I try to access the result of my ink bleed calculations.

What I just don’t understand is why it does make a visual effect on the smaller jpg and with a hard coded float in the place of my time uniform. I am new to glsl, but working through whatever material I can get my hands on. If anyone has any advice, it would be much, much appreciated. Files linked below:

ofApp.cpp http://pastebin.com/hnfmwWuK
main.cpp http://pastebin.com/pyt4Ggj8
inkspread.frag http://pastebin.com/wSaBxMpX
inkspread.vert http://pastebin.com/4kvw8NKc

Thanks!

Realized it was simple, I was setting the uniform outside of shader.begin(). Once I changed that it works. Solved!