[SOLVED] Visual Studio 2015 Project Generator

Hi all,

I’m trying out the new OF 0.9.0 with a fresh install of Visual Studio 2015 Community Edition.

After installing VS, I followed the instructions to install the OF Plugin successfully.

Attempting to generate new projects, I get up to selecting addons, then after continuing it attempts to create a project and I get this error…

Any advice on what might be causing this?


1 Like

Problem solved. I think the installation instructions should be updated to reflect this.

Needed to install the Common Tools for Visual C++ 2015. This is done by trying to make a C++ Project then following the prompts to install the tools.

Any advice on how I can update the Visual Studio Install Guide on the OF website? The typical installation doesn’t include the C++ tools it seems so the instructions should be updated to reflect this.



It should prompt you when you install Visual Studio what tools to install, did you deselect all options when installing?

If you want to make changes to the site look here

Yeah it did prompt me to install, though I stuck to the instructions of selecting the Typical Install option, which doesn’t include the C++ tools.

I’ll update the instructions as soon as I get a chance. Thanks for the link.

I had the same problem. Installing common tools solved it.
Thank you!

1 Like

I’ve added the instructions on Github but I don’t know how to upload the images.

Thanks for this, I was having the same issue, :slight_smile: