[solved] Recent update of codeblocks or libwxbase broken

Hey, I’ve been using 0061 on Ubuntu 9.10 for a while, everything has been great. However sometime last week there were new versions of both codeblocks (8.02svn6261) and wx (2.8.11.0-0). I usually ignore updates to these packages to avoid problems like this, but I figured it is summer and I can finally upgrade my system.

Now I’m getting the good old runtime error when I try to start codeblocks:

  
  
codeblocks: relocation error: /usr/lib/libcodeblocks.so.0: symbol _Z18wxSafeConvertWX2MBPKw, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference  
  

synaptic says codeblocks depends on wx versions 2.8.10.1 or higher. I’ve tried forcing the version of libwxbase to 2.8.10.1 but it wants to uninstall codeblocks when I try to do that. then when I reinstall codeblocks, it upgrades wx. If I lock the version of wx, it says it is incompatible, but the version should be fine!

I’ve also tried to downgrade codeblocks to a previous version with no success. It tells me I have broken packages when I try to force a previous version.

Is anyone using the aforementioned package versions without any problems? I even tried removing everything, including the repositories and re-running the install_codeblocks.sh script. No luck!

Okay, so maybe I just didn’t try hard enough in synaptic, I never use it anyway. I found out that I can force install from the command line using apt-get like this:

  
  
sudo apt-get install codeblocks=8.02svn6088 codeblocks-common=8.02svn6088 libcodeblocks0=8.02svn6088 codeblocks-contrib=8.02svn6088 libwxsmithlib0=8.02svn6088 codeblocks-contrib-common=8.02svn6088  
  

Codeblocks is back to its old self now, I guess the new version isn’t stable. Hopefully someone else who has this problem can fix it this way too!

just encountered the same problem but can’t seem to solve it as above … help

http://forum.openframeworks.cc/t/codeblocks-libwxbase-problem/4051/1

When you go to synaptic and look at the codeblocks package, right click and go to properties ->versions tab, what versions are available to you?

Here is what I see:
[attachment=0:1c8nrdwj]codeblocksversions.png[/attachment:1c8nrdwj]

8.02svn6181-0~karmic(karmic-lgp)
8.02svn6088-0~karmic(karmic-lgp)
8.02svn6023-0~karmic(karmic-lgp)
8.02-0ubuntu4~karmic(karmic-lgp)

only the top one will install the others do things like remove libraries or crash

however, the top one is the one with the wxwidgets problem

So if you open a terminal and paste this in:

  
sudo apt-get install codeblocks=8.02svn6088 codeblocks-common=8.02svn6088 libcodeblocks0=8.02svn6088 codeblocks-contrib=8.02svn6088 libwxsmithlib0=8.02svn6088 codeblocks-contrib-common=8.02svn6088  

it doesnt work? I just tried this on a fresh install that had the same problem a few days ago, it worked fine.

Doesn’t work for me :frowning: This is the read out I get .

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Version ‘8.02svn6088’ for ‘codeblocks’ was not found

oh, okay. it looks like for you you’ll want to add the ‘-0~karmic’ to the end, just like the version from synaptic tells you. so try this:

  
sudo apt-get install codeblocks=8.02svn6088-0~karmic codeblocks-common=8.02svn6088-0~karmic libcodeblocks0=8.02svn6088-0~karmic codeblocks-contrib=8.02svn6088-0~karmic libwxsmithlib0=8.02svn6088-0~karmic codeblocks-contrib-common=8.02svn6088-0~karmic  

I’m not sure why yours is named differently

alas no … still the same message :frowning:

I actually just upgraded to Ubuntu 10.4 on my 2nd machine and OF is working great there so now I’m going to do it with my other one instead of continuing to battle against this.

but thanks for your help

Another way to get this working is to remove the wxwidgets repository completely and use the ubuntu version. then you can upgrade to the latest svn of codeblocks. I have it working on 9.10 and 10.04