“breakthrough” that is…

finally managed to install the libusb drives and solve the dll error

  1. download the zadiq app
  2. download the libfreenect inf folder from latest branch

run the app as admin

select the kinect camera

but here is the twist

DO NOT USE THE default libusb drivers that the app tries to install, (like it says in the README FILE)

point directly into the correct folder of the 64 bit .sys and dll
like in the old instructions (in the INF folder inside ofxkin/platfrm/windws)

this will successfully install the drivers :slight_smile: so easy if you know how to do it :slightly_smiling:



is that I get a similar error I got under UBUNTU!!! WTF!!!

see the above pictures and let me know what you think

I will post more debugging data as soon as possible!

can it be a windows authorization thing?



I CANNOT JUST BUY A NORMAL KINECT because where I live it takes a month to get plus it will cost a fortune just for shipping,. …. :disappointed_relieved:

I can arrange a team-viewer if anybody wants to take a look

Guys this is unbelievable …… FUCKING… UNBELIEVABLE!!!


clicked Delete the driver…


Then out of curiosity to see what Error I would get this time I run the example….

I still cannot believe it… but miraculously it worked!!!


I’ve been trying to make this work for 2 MONTHS NOW…

I am scared to quit and run it again… I am afraid it will never work again!!!

1 Like

lol… it was just a drivers issue after all…

Interesting. I too want to use a Kinect for a project. Still very much in the reading phase.

Why do you swear?


it’s not a swear :blush: it’s my victory roar…

I recently bought an i7 NUC and started working for a small project on my spare time and I’ve been very stressed because instead on focusing on my code I was struggling to set it up for 2 months.

at first I installed ubuntu but there was a problem with the usb3.0 ports *it worked FINE on my other 2.0 ubuntu machine. (celeron mini pc)

so i decided to use windows and also take advantage of the IR of the NUC

… I think the Readme file for windows is far from clear and it leaves A LOT OF THINGS in chance for some windows systems.

I was lucky when I tested my kinect a few years ago and got it right …

but this time around it was a struggle

here is what worked for me:

a) never connect the kinect for the first time if you are online.

b) download the zadiq app open it

go offline.

c) run the app as admin

d) connect the kinect

e) DO NOT INSTALL THE DEFAULT libusb-win32( v1.2.6.0 ) DRIVERS THE APP and the openframeworks. README recommends because it didn’t work for me that way I got the dll error. I think it only works for 32bit machines

f) point the app to the kinect drivers inside the inf folder in the ofxkinect addon.

note : be offline the entire time.
do not allow windows to install its shitty drivers

g) try the example, if it doesn’t work and you don’t get the dll then you have the shitty windows drivers installed and it conflicts, go to device manager and uninstall the kinect and delete the drivers
so that you avoid conflicts

restart and try again. to run the app. (don’t install anything again) if it doesn’t work and you get dll error repeat installation till it does.


Pro tip

if you haven’t got a PC or a kinect yet and you are going to buy new equipment anyway…

buy a mac mini or another osx device. - it works straight up. plus you get to code in XCODE not VS or whatever other sub-par IDE.

unless you don’t value your time

Thanks very much dude for you solution! i have f// kinect for windows, and i thought it impossible, run it on my laptop with win10. Now it work!

Windows 10 64bit / Visual Studio 2015 Comuunity / Kinect Xbox 360 (original)
Step by step how to install drivers for working with libfreenect

0- Download Zadiq app: and open it (as admin)
1- Go offline
2- Plug Kinect
3- Go to Device Manager in your computer
4- Uninstall all of the libusbK drivers if there are still any that are installed automatically
5- In Zadiq click “list all devices” and “advanced mode” under options menu
6- click the folder icon next to driver and select the folder openFrameworks\addons\ofxKinect\libs\libfreenect\platform\windows\inf
7- repeat the steps 7.1 to 7.3 for Xbox motor, camera and audio
7.1- From the list of devices drop down menu select Xbox Motor NUI
7.2- In the driver list to be replaced to (right side of the green arrow) select “libusb-win32 (v1.2.6.0)”
7.3- Click “Reinstall driver”


I was facing driver problem in Win 10. Followed this tutorial to install old version drivers for Win10. The link is not for Kinect camera but its helpful to install the drivers.

Thanks to all for contributing.

Hi everyone

OK there are many replies for this

But I tried them but they seem just not working.

Are all of these solutions for installing Kinect 360 working on windows 10 64bit?

Can someone please help me install it ?

I also ran into similar driver errors recently on an install where I was using three NUCs, three KinectV2s, and an OF app that relied on ofxKinectForWindows2. I found that the easiest way to solve this problem was to install a full version of VisualStudio2017 on each of the run machines. After installing that and the Kinect2SDK these driver errors cleared themselves up. I’m not sure if a similar approach would work with the original Kinect but it might be worth a shot.

Hope this helps.

Got it! Let me try this one. Hope it will work for me. Been using Kinect V2 before, hope this one will work out. Go2top.

I was also having issues with the Kinect 360 model 1414 on Windows 10 and 64 bit. I tried installing the newest drivers using zadig as described in the ofxKinect folder, but it didn’t work. I found this post, installed the older drivers and now it works great.


Expanding on this -

I was having issues with libusbK drivers (installed through Zadig app) on Win 10 with Kinect 1414.

I had installed the latest driver version libusbK 3.0.7. Every time I exited the app, the Kinect would freeze and I would get Isochronous errors if I restarted the app. (Only way to solve was to unplug / replug Kinect.)

Downgrading the drivers to libusbK 3.0.6 solved it.

I installed the downgraded drivers using older zadig (from Nick’s link):


Can somoene help me with this, I am the original XBOX 360 Kinect and I read through the posts there but seems to have different options but leading to install old drivers

So please guide me, as I am not sure where I am wrong

I found this page after attempting to download runtime, developer kinect etc, but I removed them from Programs and features

I downloaded the zadig 2.0.1 ( the older one )
I run as ADMIN
I insert the Kinect which is pre blinking green for me
I choose these 3 one by one?


ONLY install this driver?

or pick WINUsb?

I tried either/or and BOTH but Windows cant find my camera

Please, a bit more detailed guide, appreciate it

What are you trying to do exactly? The kinect examples that come with openframeworks should have the driver bundled, so you should uninstall the kinect sdk and then go to device manager and select the kinect (whatever drivers it has) and uninstall device (then check the box to delete the driver). You may need to do this twice on your setup.

The instructions you have followed are for replacing the original microsoft driver with a libusb driver. You should not need this to work with the kinect and the basic openframeworks examples.

There are some addons that may use the kinect differently and have different references to the libusb driver.

I am trying to install XBOX360 Kinect to Windows 10, so forget everything
Can u tell me exact steps as if I am starting over

Yes but what are you trying to do with it, are you just trying to use the examples that use ofxKinect that is bundled with openframeworks?