[SOLVED] ofxUI-examples not working in xcode 4.2

Hi,

I’m using xcode 4.2 with OF and the Reza UI (http://www.syedrezaali.com/blog/?p=2172). None of the example-xcodeprojects work, except for the ofxUICustomization one. When building the projects I get the following error message:

  
clang: error: no such file or directory: '/Users/david/Documents/xcode/of_v0073_osx_release/apps/ofxUI-master/example-ofxUIVariableBinding/../../ofxXmlSettings/libs/tinyxml.cpp'  
clang: warning: -lpthread: 'linker' input unused  
Command /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang failed with exit code 1  
  

What is wrong here? I already changed the Base SDK, the Architecture, but no change :frowning:

Did anyone have the same issue?

Greetz,

David

it works for me on xcode 4.5. where did you clone the code? It should be in your addons folder.

Hey M_Drive,

Thx for your quick response.
Actually I’m working in xcode 4.6, just noticed that (I’m really new to all of this, coming from max/msp and pd-programming).

Your question about where I cloned the code made me look at the addons folder again. I noticed that the files in the required ofxXmlSettings-addon where red-coloured. Apparently there’s a linking problem with these files, so I removed the addon and imported it again: solved!

Thx,

David