SOLVED - ofxMsaPhysics not working with 007oF

Hi all,

I am trying to use ofxMsaPhysics to generate some 3D environment with of007. I am using both xCode and codeBlocks.

I have tried to compile the examples included here https://github.com/mchinen/ofxMSA.

In both OSX Lion and Linux, in two different computers, I get this error:

  
			glutSolidCube(1);                    Use of undeclared identifier 'glutSolidCube'  

I suppose this has some relation with the lib glut.h or glu.h but i can’t figure out how to solve this.

well… any ideas?

thks in advance!

MSAPhsyics worked “out the box” for me on OSX. Did you add its dependencies (MSACore and MSAObjCPointer)?

yes, in both projects.

i really don’t understand what’s going on…

Did u run the application in OSX Lion?

are you using ofxMSAPhysics (version 2 i guess) or MSA physics?

thks in advance.

_j

Yes, OSX Lion, XCode 4.

The version I used is here: https://github.com/memo/msalibs
Looks like it is different- I think it’s more up to date but not 100% sure.
Hope that helps.

damm

i tried with this version.

i still get the same error.

thks for the help

by the way, the version you posted is 1.2

the link in the first post is 2.1.

The changelog disagrees: says it’s version 3.1.

I just tried to compile the examples you’ve linked but I get lots of errors because of the library versions I have. At a guess, I’d say the examples probably aren’t compatible with of007.

i think glutSolidCube isn’t implemented anymore

Have you tried to include glut in testApp.h? i mean:

#include <GL/glut.h>

(could be different depend by the system…)
because in OF 007 glut isn’t in the OF lib by default. This should fix the problem. Or you have to include it where the errors point out.

ouch.

that solved the problem.

thkx for posting!