[Solved| ofxGui controls does not work as expected!

Hi there,
I installed nightly build linux64 gcc6 recently
everything seems to work fine execpt ofxGui ,
well the problem is I don’t see names I define for controls on them ,
and on group controls I can’t expand them or collapse them …
I’m not able to test with another OS or another version of OF to see if problem still exist
( I use Arch Linux with Gnome DE )
(So does anyone else faced the same issue ?! or any ideas on how to fix it ?!)

This screenshot might describe the situation better than I do :)) :smiley:
( examples/gui/guiExample )

can you check if the 3dprimitivesExample works well for you?

well …
s and w keys does nothing . and ‘a’ key acts strange ! I would not say that straight line moving from left to right of my display is an axis !

app start like this ! pressing s and w does nothing !

result of pressing n

that’s strange ! I can’t guess what would be wrong with this !

ps :
~>$ ./bin/3DPrimitivesExample
[warning] ofInit: Couldn’t set UTF-8 locale, string manipulation functions
won’t work correctly for non ansi characters unless you specify a UTF-8 locale
manually using std::locale::global(std::locale(“locale”))
available locales can be queried with ‘locale -a’ in a terminal.
[notice ] ofGstVideoGrabber: Probing devices with udev…
[notice ] ofGstVideoGrabber: Found device 13d3:5165, getting capabilities…
[notice ] ofGstVideoGrabber: detected v4l2 device: USB Camera
[notice ] ofGstVideoGrabber: driver: uvcvideo, version: 265224
[notice ] ofGstVideoGrabber: Capabilities: 0x84200001
[notice ] ofGstVideoGrabber: initGrabber(): selected device: USB Camera
[notice ] ofGstVideoGrabber: initGrabber(): selected format: 640x480 video/x-raw RGB framerate: 30/1
[notice ] ofGstUtils: setPipelineWithSink(): gstreamer pipeline: v4l2src name=video_source device=/dev/video0 ! video/x-raw,format=RGB,width=640,height=480,framerate=30/1 ! appsink name=ofappsink enable-last-sample=0 caps=“video/x-raw, format=RGB, width=640, height=480”

I don’t see anything useful here !

this is a known bug with certain video cards drivers in linux. if you go into libs/openframeworks/gl/ofBufferObject.cpp and change every line that says:

if (GLEW_ARB_direct_state_access) {

to:

if (false) {

that should fix the problem

2 Likes

Thanks again sir.
It’s the second time you help me out and I don’t know how to thank you !

so should I expect bug fixes for this ? or should i install another driver for Video Card ( PLZ NO! :smiley: )??

to whom, it may concern :smile:
I’m using laptop with optimus technology , Intel HD graphics and a dedicated NVidia one & open-source xf86-video-intel and xf86-video-nouveau drivers, and mesa ( an open-source implementation of the OpenGL specification )

The trick mentioned by arturo and compiling the OF fixed my problem :slight_smile:

we’ll fix this before releasing the next release

1 Like