[solved] No datas when bin is uploaded and then downloaded (osx)

Hey folks,

I was trying to send my app to someone by compressing the bin/ folder and upload it to Google Drive, but when it’s downloaded and uncompressed, the app cannot access the data folder (no images displayed).

  • app is built with oF 0.9.8
  • xcode and manual make produces the same, debug or release
  • it’s sent from a macOS 10.13.x computer to another macOS 10.13.x computer
  • I’ve tried zip and tar.gz, same issue.
  • the app works as expected when builded and run on the my computer

The really weird thing is that it worked when the .app (as is) and the data/ (compressed) are downloaded separately and manually put together into a common directory. Same if I download the whole bin/ folder and manually move the twos into another folder … :thinking:

Here’s an example app simply displaying an image, that I’ve gzipped and uploaded to Google Drive:

Steps to reproduce:

  • download the whole tar.gzarchive
  • uncompress it, run the no-datasDebug.app and see no image
  • create a new folder anywhere
  • copy (or move) .app and data/ one at a time inside this new folder
  • ¿ black magic does its tricks ?
  • run the .app and see the image

One can easily get around this, with the steps I described, or by packaging the data inside the app contents (haven’t tested), but this is still some pretty weird thing happening here !

p.s: I haven’t tested with other platform.

osx does this thing called translocation where running an app downloaded from somewhere will run the application from a random folder for security reasons. the only way to avoid it is to move the .app itself somewhere else, then osx will remove the unsafe attribute and won’t use translocation anymore.

2 Likes

Oh, I had no idea ! Thanks !