[SOLVED] lucid and GStreamer video problems

Hello,

I’m in the process of porting an app made on mac (OF v0061) to linux (master downloaded from github) and ran into some problems with playing a video. So thought I would try some movie example first and that didn’t work either.

If I try to run the moviePlayerExample I get the following with the log level set to verbose:

  
OF_VERBOSE: loading file:///home/ping/Projects/openframeworks/openframeworks-openFrameworks-7330fd5/apps/examples/moviePlayerExample/bin/data/movies/fingers.mov  
  
(<unknown>:3786): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed  
  
(<unknown>:3786): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed  
  
(<unknown>:3786): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed  
  
(<unknown>:3786): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed  
OF_ERROR: GStreamer: unable to set pipeline to paused  
  
OF_ERROR: ofVideoPlayer couldn't load movie  
OF_ERROR: ofVideoPlayer::play - movie not loaded!  
Segmentation fault  
  
Process returned 139 (0x8B)   execution time : 0.160 s  
Press ENTER to continue.  

I can play the fingers.mov with dragon player so the codecs should be OK.

BTW I had the -lunicap issue also but just removed the library in the codeblocks build setup, I did not download the new fixed master as mentioned in http://forum.openframeworks.cc/t/[solved]-compile-from-latest-github-quot;cannot-find–lunicapquot;/4700/0

Any idea what can be the cause?

Thanks,
lq

Can you try and play the fingers.mov with Totem, the default media player for Lucid?
That’s based on GStreamer. I haven’t tried dragon player before.

Are you on 32 or 64 bits ubuntu?

I run 64bit Kubuntu. Just managed to run the example, had another look at it and it was indeed a codec issue. Apparently Dragon player doesn’t use GStreamer as a back end.

  
sudo apt-get install gstreamer0.10-plugins-base gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-plugins-good  

did the trick and now the example runs fine! Maybe this could be added to the install_dependencies.sh script.

Thank you!

lq