SOLVED - Jump to Definition reaaaally slow and unreliable

Hey everyone, hope you’re all well!

I thought I’d share a fix I just found for this problem I’ve had for years now where CMD-Click to jump to definition in Xcode is super slow and unreliable.

I followed the steps in this article, and now it seems fine again!

Will update if I encounter issues again. And let me know if you’ve had the same issue, and if you’ve fixed it some other way.

Seb

Yes, thank you for sharing. This has been a huge problem for me on Xcode, it was running so slow. Though my solution was to switch to Visual Studio Code :wink:

Ah well I think the issue may have come back again so who knows. You’re using vscode on MacOS? Any tips as to how to get that set up?

The project generator supports VScode.
You’ll have to enable Advanced Options for the drop down to appear.

1 Like

I also installed the C/C++ extension that helps with debugging and intellisense

To compile, select Terminal / Run Build Task and then Build Release
image

2 Likes

Thanks for the guide. Can you please share the IntelliSense Configurations ?
Autocompletions doesn’t works for me and I get errors messages: Cannot find: /usr/local/bin/gcc-8

Cannot find: /usr/include
Cannot find: /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/include/c++/4.2.1
Cannot find: /usr/include

I think you will still need Xcode installed and Xcode Command Line tools installed.
Hope that helps!

Theo

1 Like

I already have the Xcode installed.

I deleted the error lines or updated the path to gcc.
There are a few pesky error squiggles around, but the app compiles for me. Would love to figure out how to configure the cpp extension without errors. This is the c_cpp_properties.json file I have.
c_cpp_properties.json.zip (1.4 KB)

2 Likes