[SOLVED] Installing Dependencies errors in Ubuntu 15.10 ?¿

Hi OFs !

I’ve made a clean install of Ubuntu 15.10 … and i was willing to install OF 0.9 (with both versions : the one downloaded from the website, and the latest from nighltybuilds …)
And when i was installing dependencies with the script i got dependencies problems …

Running on ubuntu 15.10
Obj http://es.archive.ubuntu.com wily InRelease
Obj http://es.archive.ubuntu.com wily/main Sources
Obj http://es.archive.ubuntu.com wily/restricted Sources
Obj http://es.archive.ubuntu.com wily/universe Sources
Obj http://es.archive.ubuntu.com wily/multiverse Sources
Obj http://es.archive.ubuntu.com wily/main amd64 Packages
Obj http://es.archive.ubuntu.com wily/restricted amd64 Packages
Obj http://es.archive.ubuntu.com wily/universe amd64 Packages
Obj http://es.archive.ubuntu.com wily/multiverse amd64 Packages
Obj http://es.archive.ubuntu.com wily/main i386 Packages
Obj http://es.archive.ubuntu.com wily/restricted i386 Packages
Obj http://es.archive.ubuntu.com wily/universe i386 Packages
Obj http://es.archive.ubuntu.com wily/multiverse i386 Packages
Obj http://es.archive.ubuntu.com wily/main Translation-ca
Obj http://es.archive.ubuntu.com wily/main Translation-en
Obj http://es.archive.ubuntu.com wily/multiverse Translation-ca
Obj http://es.archive.ubuntu.com wily/multiverse Translation-en
Obj http://es.archive.ubuntu.com wily/restricted Translation-ca
Obj http://es.archive.ubuntu.com wily/restricted Translation-en
Obj http://es.archive.ubuntu.com wily/universe Translation-ca
Obj http://es.archive.ubuntu.com wily/universe Translation-en
S'està llegint la llista de paquets… Fet
detecting latest gstreamer version
Package: libgstreamer1.0-dev
Priority: optional
Section: libdevel
Installed-Size: 4719
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Maintainers of GStreamer packages <pkg-gstreamer-maintainers@lists.alioth.debian.org>
Architecture: amd64
Source: gstreamer1.0
Version: 1.6.0-1
Depends: libgstreamer1.0-0 (= 1.6.0-1), libc6-dev | libc-dev, pkg-config, libglib2.0-dev, libc6 (>= 2.4), libglib2.0-0 (>= 2.32), gir1.2-gstreamer-1.0 (= 1.6.0-1)
Recommends: debhelper
Suggests: gstreamer1.0-doc
Filename: pool/main/g/gstreamer1.0/libgstreamer1.0-dev_1.6.0-1_amd64.deb
Size: 368116
MD5sum: d76f99f206074782980bb06c074653c2
SHA1: f0d8930db0839aacc5137d6cd5923d9b01058873
SHA256: b0fbbf7c22df33d920ec86d679a4ea16557ae26c7a1d6b4ee026174711b6b296
Description-en: GStreamer core development files
 GStreamer is a streaming media framework, based on graphs of filters
 which operate on media data.  Applications using this library can do
 anything from real-time sound processing to playing videos, and just
 about anything else media-related.  Its plugin-based architecture means
 that new data types or processing capabilities can be added simply by
 installing new plug-ins.
 .
 This package contains development files for the core library and
 elements.
Description-md5: de1692260510350a48f76ec91eae40a9
Homepage: http://gstreamer.freedesktop.org
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 9m

selecting gstreamer 1.0
detecting latest gtk version
Package: libgtk-3-dev
Priority: optional
Section: libdevel
Installed-Size: 13303
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Architecture: amd64
Source: gtk+3.0
Version: 3.16.7-0ubuntu3
Depends: libgtk-3-0 (= 3.16.7-0ubuntu3), gir1.2-gtk-3.0 (= 3.16.7-0ubuntu3), libgtk-3-common, dconf-gsettings-backend | gsettings-backend, libglib2.0-dev (>= 2.43.4), libgdk-pixbuf2.0-dev (>= 2.30.0), libpango1.0-dev (>= 1.36.7), libatk1.0-dev (>= 2.15.1), libatk-bridge2.0-dev, libcairo2-dev (>= 1.14.0), libepoxy-dev (>= 1.0), libx11-dev, libxext-dev, libxinerama-dev, libxi-dev, libxrandr-dev, libxcursor-dev, libxfixes-dev, libxcomposite-dev, libxdamage-dev, pkg-config, libegl1-mesa-dev, libwayland-dev (>= 1.5.91), libxkbcommon-dev, libmirclient-dev (>= 0.13.3)
Suggests: libgtk-3-doc
Filename: pool/main/g/gtk+3.0/libgtk-3-dev_3.16.7-0ubuntu3_amd64.deb
Size: 858876
MD5sum: 82b98e60413744a27bc4644ddf8c6d48
SHA1: 0ee5265a9d5f4e6cadaffd62076ce286dd0767a2
SHA256: 50d64463cce4671ada7da85f30f64d9b6679ad8615efe197f73f8d76a4eedc1f
Description-en: development files for the GTK+ library
 GTK+ is a multi-platform toolkit for creating graphical user
 interfaces. Offering a complete set of widgets, GTK+ is suitable
 for projects ranging from small one-off tools to complete application
 suites.
 .
 This package contains the header and development files which are
 needed for building GTK+ applications.
Description-md5: 5e247317651e3625eb226ee49f0cfec7
Multi-Arch: same
Homepage: http://www.gtk.org/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 9m

selecting gtk 3
installing OF dependencies
S'està llegint la llista de paquets… Fet 
S'està construint l'arbre de dependències       
S'està llegint la informació de l'estat… Fet
Nota: s'està seleccionant «libsndfile1-dev» en lloc de «libsndfile-dev»
g++ ja es troba en la versió més recent.
S'ha marcat g++ com instaŀlat manualment.
No s'han pogut instaŀlar alguns paquets. Això pot ser degut a que heu
demanat una situació impossible o que esteu emprant la distribució
«unstable» i alguns paquets requerits encara no han estat creats o bé
encara no els hi han introduït des d'«Incoming».
La informació següent pot ajudar-vos a resoldre la situació:

Els següents paquets tenen dependències sense satisfer:
 libcairo2-dev : Depèn: libpng-dev
 libfreetype6-dev : Depèn: libpng-dev
 libgtk-3-dev : Depèn: libgdk-pixbuf2.0-dev (>= 2.30.0) però no serà instaŀlat
 libopencv-dev : Depèn: libopencv-objdetect-dev (= 2.4.9+dfsg-1ubuntu6) però no serà instaŀlat
                 Depèn: libopencv-highgui-dev (= 2.4.9+dfsg-1ubuntu6) però no serà instaŀlat
                 Depèn: libopencv-legacy-dev (= 2.4.9+dfsg-1ubuntu6) però no serà instaŀlat
                 Depèn: libopencv-contrib-dev (= 2.4.9+dfsg-1ubuntu6) però no serà instaŀlat
                 Depèn: libopencv-videostab-dev (= 2.4.9+dfsg-1ubuntu6) però no serà instaŀlat
                 Depèn: libopencv-superres-dev (= 2.4.9+dfsg-1ubuntu6) però no serà instaŀlat
                 Depèn: libopencv-ocl-dev (= 2.4.9+dfsg-1ubuntu6) però no serà instaŀlat
                 Depèn: libcv-dev (= 2.4.9+dfsg-1ubuntu6) però no serà instaŀlat
                 Depèn: libhighgui-dev (= 2.4.9+dfsg-1ubuntu6) però no serà instaŀlat
                 Depèn: libcvaux-dev (= 2.4.9+dfsg-1ubuntu6) però no serà instaŀlat
 libsndfile1-dev : Depèn: libsndfile1 (= 1.0.25-9.1) però s'instaŀlarà 1.0.25-9.1ubuntu0.15.10.1
 libssl-dev : Depèn: libssl1.0.0 (= 1.0.2d-0ubuntu1) però s'instaŀlarà 1.0.2d-0ubuntu1.2
              Recomana: libssl-doc però no serà instaŀlat
E: No es poden corregir els problemes, teniu paquets retinguts que estan trencats.
error installing dependencies, there could be an error with your internet connection
if the error persists, please report an issue in github: http://github.com/openframeworks/openFrameworks/issues

Can anyone give me a hand on it ? I read some issues in Github but can’t find the solution on how to solve dependecy issues …

https://github.com/openframeworks/openFrameworks/issues/4601
https://github.com/openframeworks/openFrameworks/issues/4656

Well … I rebooted the machine … tried again … and it worked …
Anyone could explain me what was going on ? And why it’s ok now ?
So … [SOLVED] … by rebooting ?