[solved] How to make ofxOpenNI works since the openNI website is down?

Hi,
I want to use an Xbox Kinect with a Windows 7 64bit OS. ofxKinect works fine, but I need features such skeleton tracking, so I’m trying ofxOpenNI.
It isn’t possible to follow the addon installation procedure because the openNI website no longer exists (since Apple bought PrimeSense I guess).
I made some researches and tries, but nothing works. Can anyone help or point me to the right direction ?

Here’s my last try:

Installation:

According to this page I have downloaded https://code.google.com/p/simple-openni/downloads/detail?name=OpenNI_NITE_Installer-win64-0.27.zip.
I have installed OpenNI: openni-win64-1.5.4.0-dev.msi
Then the Kinect driver: SensorKinect093-Bin-Win64-v5.1.2.1.msi from https://github.com/avin2/SensorKinect (recommended driver in the addon installation procedure)
Then NITE: nite-win64-1.5.2.21-dev.msi
When I plug the Kinect I see it in the Windows devices manager (PrimeSense Kinect audio, Kinect Camera and Kinect Motor) and the Kinect green led is blinking.

Running the app:

Then I build the src-ImageAndDepth-Simple example.
I put the lib folder (from the copy_to_data_openni_path addon folder) in the bin/data/openni folder
As the app complain about the missing OpenNI.dll, I also copy it from the copy_to_data_openni_path/lib folder to the bin folder.
Then the app is running, but I see nothing on the display (except the fps), and I’ve got the following message in the console:

.
[notice ] ofxOpenNIDevice[0]: Init context…
[verbose] ofxOpenNIDevice[0]: Context initilizedstatus:The environment variable could not be found!
[ error ] ofxOpenNIDevice[0]: Context could not be initialized
[notice ] ofxOpenNIDevice[0]: Adding generator typeXN_NODE_TYPE_DEPTH
[ error ] ofxOpenNIDevice[0]: Context is not setup - please call ofxOpenNI::setup() first
[notice ] ofxOpenNIDevice[0]: Adding generator typeXN_NODE_TYPE_IMAGE
[ error ] ofxOpenNIDevice[0]: Context is not setup - please call ofxOpenNI::setup() first
[notice ] ofxOpenNIDevice[0]: Starting ofxOpenNI with threading
[verbose] ofEvents: OF app is being terminated!

Thank you for any tip !

P.S: Windows 7 64bit / OF 8.0 / Code::Blocks

I’m pretty sure you need to use the 32 bit libs and not the 64 bit ones

Try using the Kinect Common Bridge. It does everything the Kinect SDK can do but inside OF

@az_rr

I’ve already tried the 32 bit libs, unsuccessfully.
Following your advice I just tried it again :
Program first complained about missing functions in OpenNI.dll. Then I replaced it by the one found in the C:\Program Files (x86)\OpenNI\Bin\ folder, and shazam, it works :slight_smile:

@theDANtheMAN

I believe this addon is for Kinect for Windows, isn’t it ? Mine is a Xbox one.

Thanks to both of you, I was stuck but now I can play with my new toy !

Check out the CommonBridge that support all of those features

I read it seems possible to use an xbox 360 sensor with the kinect for windows sdk : http://www.microsoft.com/en-us/kinectforwindows/meetkinect/faq.aspx
But I’m currently running windows 7 and the sdk require windows 8.
As I made openNI to work, I don’t think I will further investigate.
But thank you :smiley: