[Solved] Compiling error : Undefined symbols ?

Hello,

I’m new at openframeworks and c++ coding. I’ve done a bit of processing and a lot of quartz composer programming.

I’ve managed to create a simple program creating my own classes and objects.

But I still can’t compile any of memo’s addons. I’ve been trying to concentrate on the SimpleGui addon.

I’m using 10.6 with the latest openframeworks build (from Github) and the latest update of xcode. Updating as removed many of the errors, but the example code still doesn’t compile. I get this error just before creating the application :

  
Undefined symbols:  
  "std::basic_ostream<char, std::char_traits<char> >& std::basic_ostream<char, std::char_traits<char> >::_M_insert<double>(double)", referenced from:  
      ofToString(double, int)in openFrameworks.a(ofUtils.o)  
ld: symbol(s) not found  
collect2: ld returned 1 exit status  

I’m really lost… Can anyone point me to the possible error(s) ?
Thank you very much :slight_smile:

Never surender ! :slight_smile:

I’ve just read the sticky about xcode and snow leopard. The post pointed me to the project setings window. And after changing the Base SDK to 10.6 (instead of 10.5) the example compiled perfectly !

Hope it helps other newbies.