[Solved] Codeblocks crashed on lucid 10.04 linux

codeblocks: relocation error: /usr/lib/libcodeblocks.so.0: symbol _Z18wxSafeConvertWX2MBPKw, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference

No resonable answer inside ubuntu forum.
Linux crashes all the time.

The answer is here:
http://forum.openframeworks.cc/t/codeblocs-error-after-upgrading-to-ubuntu-karmic/2784/0

Seems to be a problem with the repositories. You need to downgrade a package.

that works .

just add deb http://apt.wxwidgets.org/ jaunty-wx main
to your software soruces and do a update & upgrade.

and when i checked my libwxbase2.8-0 package in synaptic , i had these packages available for me to force:
Ctrl+E
and i force the 2.8.11.1-0ubuntu1 (lucid update)
but i download from somewhere only the file install_codeblocks.sh

install_codeblocks.sh.tar.gz

I’m sorry i got problem again.
As i’m trying to fix my nvidia driver.
i include the repo
deb http://apt.wxwidgets.org/ jaunty-wx main
to your software soruces and do a update & upgrade.
i forced the 2.8.10.1-0 (jaunty-wx) downgrade.
and when i make :
sudo ./install_codeblocks.sh
wants to make an update of the libwxbase2.8
and it installs codeblocks 10 not 8 .
Can you help me again?

Why are you trying to install the earlier version of Codeblocks?

what should i do?
i’m not trying to install the earlier version. after downgrade to 2.8. when install codeblocks want to upgrage it again and installs codeblocks 10.05.

All thought i got problems with nvidia and black screen on my 9200m gs,
i want to start testing OF.
Supercollider is a dream this days. just help me to fix codeblock.

codeblocks 10.05 will be included in the next ubuntu version being released in october so there won’t be any need to install the svn version. meanwhile can you try to install it from this ubuntu ppa:

https://launchpad.net/~ubuntu-backports-…-rchive/ppa

if you continue having problems try deleting the cache as is described in the setup documentation:

http://www.openframeworks.cc/setup/linux-codeblocks