[Solved] Cannot install oF 0.9.0.. help

I cannot install oF 0.9.0.
check this log… while ./install_dependencies.sh
anyone help?

detecting latest gstreamer version
Package: libgstreamer1.0-dev
Priority: optional
Section: libdevel
Installed-Size: 4075
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Maintainers of GStreamer packages <pkg-gstreamer-maintainers@lists.alioth.debian.org>
Architecture: amd64
Source: gstreamer1.0
Version: 1.2.4-0ubuntu1
Depends: libgstreamer1.0-0 (= 1.2.4-0ubuntu1), libc6-dev | libc-dev, pkg-config, libglib2.0-dev, libc6 (>= 2.2.5), libglib2.0-0 (>= 2.32), gir1.2-gstreamer-1.0 (= 1.2.4-0ubuntu1)
Recommends: debhelper
Suggests: gstreamer1.0-doc
Filename: pool/main/g/gstreamer1.0/libgstreamer1.0-dev_1.2.4-0ubuntu1_amd64.deb
Size: 322528
MD5sum: 3e1e7b60f40ffbad3a6e1a5336c97be1
SHA1: f146c3872a3576511717fbe8a0df0a8d451bf5fd
SHA256: de6f441c81dde470c1d1cfedd0130230c95d6598ab6e1b016cec0efeb0fa476e
Description-en: GStreamer core development files
 GStreamer is a streaming media framework, based on graphs of filters
 which operate on media data.  Applications using this library can do
 anything from real-time sound processing to playing videos, and just
 about anything else media-related.  Its plugin-based architecture means
 that new data types or processing capabilities can be added simply by
 installing new plug-ins.
 .
 This package contains development files for the core library and
 elements.
Description-md5: de1692260510350a48f76ec91eae40a9
Homepage: http://gstreamer.freedesktop.org
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 9m

Package: libgstreamer1.0-dev
Priority: optional
Section: libdevel
Installed-Size: 4073
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Maintainers of GStreamer packages <pkg-gstreamer-maintainers@lists.alioth.debian.org>
Architecture: amd64
Source: gstreamer1.0
Version: 1.2.3-1
Depends: libgstreamer1.0-0 (= 1.2.3-1), libc6-dev | libc-dev, pkg-config, libglib2.0-dev, libc6 (>= 2.2.5), libglib2.0-0 (>= 2.32), gir1.2-gstreamer-1.0 (= 1.2.3-1)
Recommends: debhelper
Suggests: gstreamer1.0-doc
Filename: pool/main/g/gstreamer1.0/libgstreamer1.0-dev_1.2.3-1_amd64.deb
Size: 322684
MD5sum: 7b8c9975c0f37422fdc15ce7dbb86008
SHA1: 9f3859b95391ed9b6bcd409e5d6c351b451ffc12
SHA256: d5b749eb6e7b59b0be41c40ec1a1c5bcea94f82af59322dfdc6c2e663f4a78b8
Description-en: GStreamer core development files
 GStreamer is a streaming media framework, based on graphs of filters
 which operate on media data.  Applications using this library can do
 anything from real-time sound processing to playing videos, and just
 about anything else media-related.  Its plugin-based architecture means
 that new data types or processing capabilities can be added simply by
 installing new plug-ins.
 .
 This package contains development files for the core library and
 elements.
Description-md5: de1692260510350a48f76ec91eae40a9
Homepage: http://gstreamer.freedesktop.org
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 9m

selecting gstreamer 1.0
detecting latest gtk version
Package: libgtk-3-dev
Source: gtk+3.0
Priority: optional
Section: libdevel
Installed-Size: 10120
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Version: 3.14.15-0ubuntu1~14.04~ricotz1
Suggests: libgtk-3-doc
Depends: libgtk-3-0 (= 3.14.15-0ubuntu1~14.04~ricotz1), gir1.2-gtk-3.0 (= 3.14.15-0ubuntu1~14.04~ricotz1), libgtk-3-common, dconf-gsettings-backend | gsettings-backend, libglib2.0-dev (>= 2.41.2), libgdk-pixbuf2.0-dev (>= 2.27.1), libpango1.0-dev (>= 1.36.7), libatk1.0-dev (>= 2.7.5), libatk-bridge2.0-dev, libcairo2-dev (>= 1.10.0), libx11-dev, libxext-dev, libxinerama-dev, libxi-dev, libxrandr-dev, libxcursor-dev, libxfixes-dev, libxcomposite-dev, libxdamage-dev, pkg-config (>= 0.26-1), libwayland-dev (>= 1.4.0), libxkbcommon-dev
Filename: pool/main/g/gtk+3.0/libgtk-3-dev_3.14.15-0ubuntu1~14.04~ricotz1_amd64.deb
Size: 911348
MD5sum: 295cb2033f5b99732004b2ab7acf334e
SHA1: 9b4454e780b3c7fb94e38ba4101d14e3b6438f24
SHA256: 4b805ed7060d6b19891b1e7a6569ca8017b8e937dffe2e45e8bcf47070866138
Description-en: development files for the GTK+ library
 GTK+ is a multi-platform toolkit for creating graphical user
 interfaces. Offering a complete set of widgets, GTK+ is suitable
 for projects ranging from small one-off tools to complete application
 suites.
 .
 This package contains the header and development files which are
 needed for building GTK+ applications.
Description-md5: 5e247317651e3625eb226ee49f0cfec7
Multi-Arch: same
Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>

Package: libgtk-3-dev
Priority: optional
Section: libdevel
Installed-Size: 9628
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Architecture: amd64
Source: gtk+3.0
Version: 3.10.8-0ubuntu1.6
Depends: libgtk-3-0 (= 3.10.8-0ubuntu1.6), gir1.2-gtk-3.0 (= 3.10.8-0ubuntu1.6), libgtk-3-common, libglib2.0-dev (>= 2.37.5), libgdk-pixbuf2.0-dev (>= 2.27.1), libpango1.0-dev (>= 1.32.4), libatk1.0-dev (>= 2.7.5), libatk-bridge2.0-dev, libcairo2-dev (>= 1.13.0~20140204), libwayland-dev (>= 1.2.0), libx11-dev, libxkbcommon-dev, libxext-dev, libxinerama-dev, libxi-dev, libxrandr-dev, libxcursor-dev, libxfixes-dev, libxcomposite-dev, libxdamage-dev, pkg-config (>= 0.26-1)
Suggests: libgtk-3-doc
Filename: pool/main/g/gtk+3.0/libgtk-3-dev_3.10.8-0ubuntu1.6_amd64.deb
Size: 807100
MD5sum: 793396f3b78d6e70c42ecda45abbe54e
SHA1: 8b2178f7535cc7068877af749ee6776be04c450a
SHA256: 5fb6dd785a9513b1a42af27b683d938ed198c246fab40906b0c6b581e0b54f15
Description-en: development files for the GTK+ library
 GTK+ is a multi-platform toolkit for creating graphical user
 interfaces. Offering a complete set of widgets, GTK+ is suitable
 for projects ranging from small one-off tools to complete application
 suites.
 .
 This package contains the header and development files which are
 needed for building GTK+ applications.
Description-md5: 5e247317651e3625eb226ee49f0cfec7
Homepage: http://www.gtk.org/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Phased-Update-Percentage: 0
Supported: 9m

Package: libgtk-3-dev
Priority: optional
Section: libdevel
Installed-Size: 9627
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Architecture: amd64
Source: gtk+3.0
Version: 3.10.8-0ubuntu1.4
Depends: libgtk-3-0 (= 3.10.8-0ubuntu1.4), gir1.2-gtk-3.0 (= 3.10.8-0ubuntu1.4), libgtk-3-common, libglib2.0-dev (>= 2.37.5), libgdk-pixbuf2.0-dev (>= 2.27.1), libpango1.0-dev (>= 1.32.4), libatk1.0-dev (>= 2.7.5), libatk-bridge2.0-dev, libcairo2-dev (>= 1.13.0~20140204), libwayland-dev (>= 1.2.0), libx11-dev, libxkbcommon-dev, libxext-dev, libxinerama-dev, libxi-dev, libxrandr-dev, libxcursor-dev, libxfixes-dev, libxcomposite-dev, libxdamage-dev, pkg-config (>= 0.26-1)
Suggests: libgtk-3-doc
Filename: pool/main/g/gtk+3.0/libgtk-3-dev_3.10.8-0ubuntu1.4_amd64.deb
Size: 801750
MD5sum: 5852e25886fc66ac8461c96ff9f940fb
SHA1: 353b85c325261f2a162f6b48bcae24dc3ea1ed45
SHA256: 2875dd4354c475ae4fc4d23af8e499bac6534d57a6cdb5df31d2a197b761f4c0
Description-en: development files for the GTK+ library
 GTK+ is a multi-platform toolkit for creating graphical user
 interfaces. Offering a complete set of widgets, GTK+ is suitable
 for projects ranging from small one-off tools to complete application
 suites.
 .
 This package contains the header and development files which are
 needed for building GTK+ applications.
Description-md5: 5e247317651e3625eb226ee49f0cfec7
Homepage: http://www.gtk.org/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 9m

Package: libgtk-3-dev
Priority: optional
Section: libdevel
Installed-Size: 9627
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Architecture: amd64
Source: gtk+3.0
Version: 3.10.8-0ubuntu1
Depends: libgtk-3-0 (= 3.10.8-0ubuntu1), gir1.2-gtk-3.0 (= 3.10.8-0ubuntu1), libgtk-3-common, libglib2.0-dev (>= 2.37.5), libgdk-pixbuf2.0-dev (>= 2.27.1), libpango1.0-dev (>= 1.32.4), libatk1.0-dev (>= 2.7.5), libatk-bridge2.0-dev, libcairo2-dev (>= 1.13.0~20140204), libwayland-dev (>= 1.2.0), libx11-dev, libxkbcommon-dev, libxext-dev, libxinerama-dev, libxi-dev, libxrandr-dev, libxcursor-dev, libxfixes-dev, libxcomposite-dev, libxdamage-dev, pkg-config (>= 0.26-1)
Suggests: libgtk-3-doc
Filename: pool/main/g/gtk+3.0/libgtk-3-dev_3.10.8-0ubuntu1_amd64.deb
Size: 800374
MD5sum: cf91ca66dea0e669cc571ffdc014d420
SHA1: bc6ee005ef6c75b6f24d96e7cb1460b40a0e6f33
SHA256: aa7882af664a8c6c28e1e4e3de17019cb7b2b6109843c70039b9635de8d4f718
Description-en: development files for the GTK+ library
 GTK+ is a multi-platform toolkit for creating graphical user
 interfaces. Offering a complete set of widgets, GTK+ is suitable
 for projects ranging from small one-off tools to complete application
 suites.
 .
 This package contains the header and development files which are
 needed for building GTK+ applications.
Description-md5: 5e247317651e3625eb226ee49f0cfec7
Homepage: http://www.gtk.org/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 9m

selecting gtk 3
 installing OF dependencies with -lts-utopic packages, confirm Y/N ? ㅛinstalling OF dependencies

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libsndfile1-dev' instead of 'libsndfile-dev'
freeglut3-dev is already the newest version.
g++ is already the newest version.
libasound2-dev is already the newest version.
libglew-dev is already the newest version.
libglu1-mesa-dev is already the newest version.
libraw1394-dev is already the newest version.
libusb-1.0-0-dev is already the newest version.
libxmu-dev is already the newest version.
libxxf86vm-dev is already the newest version.
libfreeimage-dev is already the newest version.
libopenal-dev is already the newest version.
libdrm-dev is already the newest version.
libfreetype6-dev is already the newest version.
libgl1-mesa-dev is already the newest version.
libpulse-dev is already the newest version.
libsndfile1-dev is already the newest version.
libssl-dev is already the newest version.
libudev-dev is already the newest version.
libcairo2-dev is already the newest version.
libgtk-3-dev is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libboost-filesystem-dev : Depends: libboost-filesystem1.54-dev but it is not going to be installed
 librtaudio-dev : Depends: libjack-dev
E: Unable to correct problems, you have held broken packages.
error installing dependencies, there could be an error with your internet connection
if the error persists, please report an issue in github: http://github.com/openframeworks/openFrameworks/issues
icq4ever@icq4ever-x201-linux:~/Documents/oF090/scripts/linux/ubuntu$

this is a known problem that is solved already in master, can you try installing manually libjack-jackd2-dev before running the install_dependencies script?

1 Like

thanks! I tried pre install manually libjack-jackd2-dev with your suggestion, but not work.

so I download and overwrite install_dependences.sh script file.
it seems working good… but sadly. stuck agiain…

...
Unpacking mesa-common-dev-lts-utopic:amd64 (10.3.2-0ubuntu1~trusty2) ...
Setting up mesa-common-dev-lts-utopic:amd64 (10.3.2-0ubuntu1~trusty2) ...
Setting up libgl1-mesa-dev-lts-utopic:amd64 (10.3.2-0ubuntu1~trusty2) ...
Installing libglu1-mesa-dev
 Already installed
Installing libraw1394-dev
 Already installed
Installing libudev-dev
 Already installed
Installing libdrm-dev
 Already installed
Installing libglew-dev
 Already installed
Installing libopenal-dev
 Already installed
Installing libsndfile-dev
 Already installed
Installing libfreeimage-dev
 Already installed
Installing libcairo2-dev
 Already installed
Installing libfreetype6-dev
 Already installed
Installing libssl-dev
 Already installed
Installing libpulse-dev
 Already installed
Installing libusb-1.0-0-dev
 Already installed
Installing libgtk-3-dev
 Already installed
Installing libopencv-dev
Extracting templates from packages: 100%
Installing libassimp-dev
Installing librtaudio-dev
Installing libboost-filesystem-dev
E: Unable to correct problems, you have held broken packages.
error installing libboost-filesystem-dev
Reading package lists... Building dependency tree... Reading state information... Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libboost-filesystem-dev : Depends: libboost-filesystem1.54-dev but it is not going to be installed
this seems an error with your distribution repositories but you can also
report an issue in the openFrameworks github: http://github.com/openframeworks/openFrameworks/issues

somehow, this is because I’m using elementary OS, that not official ubuntu?
I tried modify /etc/lsb-release as same as ubuntu 14.04
anyway… I’ll try again with nightbuild. !

I cannot install libboost-dev-all. it looks like some kind of dependencies issue…

icq4ever@icq4ever-x201-linux:~/Documents/oF090/scripts/linux/ubuntu$ sudo apt-get install libboost-all-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libboost-all-dev : Depends: libboost-dev but it is not going to be installed
                    Depends: libboost-atomic-dev but it is not going to be installed
                    Depends: libboost-chrono-dev but it is not going to be installed
                    Depends: libboost-context-dev but it is not going to be installed
                    Depends: libboost-coroutine-dev but it is not going to be installed
                    Depends: libboost-date-time-dev but it is not going to be installed
                    Depends: libboost-exception-dev but it is not going to be installed
                    Depends: libboost-filesystem-dev but it is not going to be installed
                    Depends: libboost-graph-dev but it is not going to be installed
                    Depends: libboost-graph-parallel-dev but it is not going to be installed
                    Depends: libboost-iostreams-dev but it is not going to be installed
                    Depends: libboost-locale-dev but it is not going to be installed
                    Depends: libboost-log-dev but it is not going to be installed
                    Depends: libboost-math-dev but it is not going to be installed
                    Depends: libboost-mpi-dev but it is not going to be installed
                    Depends: libboost-mpi-python-dev but it is not going to be installed
                    Depends: libboost-program-options-dev but it is not going to be installed
                    Depends: libboost-python-dev but it is not going to be installed
                    Depends: libboost-random-dev but it is not going to be installed
                    Depends: libboost-regex-dev but it is not going to be installed
                    Depends: libboost-serialization-dev but it is not going to be installed
                    Depends: libboost-signals-dev but it is not going to be installed
                    Depends: libboost-system-dev but it is not going to be installed
                    Depends: libboost-test-dev but it is not going to be installed
                    Depends: libboost-thread-dev but it is not going to be installed
                    Depends: libboost-timer-dev but it is not going to be installed
                    Depends: libboost-wave-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

i also tried install specific package… but I got log like this…

icq4ever$ sudo apt-get install libboost-filesystem-dev

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libboost-filesystem-dev : Depends: libboost-filesystem1.54-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


icq4ever$ sudo apt-get install libboost-filesystem1.54-dev

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libboost-filesystem1.54-dev : Depends: libboost1.54-dev (= 1.54.0-4ubuntu3.1) but it is not going to be installed
                               Depends: libboost-system1.54-dev (= 1.54.0-4ubuntu3.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

that seems like something wrong in your system, try apt-get install -f and also to follow the chain of broken packages until you find out which one is the culprit. for example after:

libboost-filesystem1.54-dev : Depends: libboost1.54-dev (= 1.54.0-4ubuntu3.1) but it is not going to be installed

try executing

sudo apt-get install libboost1.54-dev

have you installed a custom version of boost on the system?

1 Like

i cannot remember whether installed boost before or not.
but with synaptic package manager, I found 1.55 boost installed.

as conversations from here, I removed 1.55boost* packages and try again install libboost-all-dev… and it works!

thank you for your help!! :smiley: