[SOLVED] Build in debug but not in release

Hi all
silly question. Codeblocks 12.11 and oF 0.8.4.
When I build the examples in release mode I get always this kind of error:

..\..\..\libs\openFrameworksCompiled\lib\win_cb\openFrameworks.lib(ofGraphics.o):ofGraphics.cpp|| undefined reference to `_Unwind_Resume'|

In debug all works well. Can someone give some hints about this?
Thanks
Paolo

Googling around it looks like this error is due to mixing versions of MinGW GCC.
Can you try deleting the openFrameworks.lib file and see if rebuilding it fixes the issue?

Are you using a MinGW install that was different from the one that comes with 12.11? ( http://openframeworks.cc/setup/codeblocks/ )

I’ve had loads of compiler issues in the past when using the wrong release of MinGW.

Hope that helps!
Theo

Thanks
ya, I was thinking something like that.
I have CB 13 and CB 12.11 installed I remove C:\MinGw\bin from the path but still doesn’t works. BTW, path on toolchains are correct…

I tried a fresh installation and remove all paths that can create some sort of conflict of mingw
but… nothing

Which Mingw compiler version does it use Codeblocks?

I mean openFrameworks not Codeblocks…

Ok. I linked also the single libraries and not only oFCompiled and it works.
It depends on the example it could be helpful give path_to\export\win_cb as search directories.

At the end I made a fresh installation of CB 12.11 and seems work better than the first.