[SOLVED] Build app for iOS 5.1.1 AND without Apple Developer account !?

Hello all !

long story short : how do you build an iOS app and transfer it to the device without Developper Program ?

now here is the detailed story :

I have built several oF apps for OSX. Now i am digging into iOS… and iOS is a shiny new world to me !

As i understand, i need openFrameworks for iOS and Xcode with iOS SDK.

Now i have a problem : i am under OSX Yosemite + Xcode 6 but the device i need the app to build to is an old iPad 1 stuck in iOS 5.1.1

I wish i could build my app for iOS 5.1.1 but i wonder if it is even possible !

Also : i don’t have an iOS Developper Program registered. Is it possible to build the app for iOS simulator and then transfer it to the device ?

Note : i don’t want the app to be available in the appstore, it is a custom and private app for an installation.

Note 2 : the iPad is jailbreaked and i have root access to its directory tree through SFTP

thanks a lot


Quite a while back I got that to work with JailCoder, but that was an older version of XCode and OS X (though also iOS 5 on an iPad 2). I just asked google real quick and it seems to be broken for recent versions of iOS, but kind of works for Xcode 6 (see the most recent post on their facebook page).

It might be worth a try or at least as a starting point for further investigation ;-).

Best, Benni.

Hello !

Thanks a lot for your feedback. I will give JailCoder a try.

Just an update from my research :

As i understand, it is possible to build for iOS 5.1. The project should be configured to use iOS 8.1 SDK but it is possible to specify to deploy for iOS 5.1. I can’t test if it works as i can’t be able to send the app to the device yet.

Now the problem is sending the app to the device without Apple Developper Program.

Here are some information i found :



which is based on :

seems promising but still can’t deploy the app as Xcode keeps complaining about Apple Developper Program, even if i disabled it in the .plist file.

Concerning the code signing : i tried a self signing code as described in the link above. still asking for an Apple Developper Program. Then i tested with configuring Xcode not tu sign code, app is building but not deployed.

Then i tried to grab the built app and send it to the device manually (in the device root Application directory, i don’t know if this is the correct path). The app appears in the device but it won’t launch.

Keep trying…

Any help much appreciated !

thanks a lot


I created a brand new simple stupid app with projectGenerator
the app just displays a white circle in the screen center.

i managed to make it to build and deploy to the device. Settings is as follow :

  • iOS 8.1 SDK
  • Deployment target iOS 5.1
  • only 32 bits
  • disable code sign

the app builds and installs to the device without asking for an Apple Developper Program registration.


the app doesn’t launch : when i click it on the iPad there is only a black screen flash (like open then instantly closes) and the message box appears in Xcode :

 process launch failed: failed to get the task for process 896

is there anything else i am doing wrong ?

is that related to the lack of code signing ?

thanks a lot

ok !

So i was able to make my simple app to work. Issue was surely related to code signing.

Here are the steps for this simple app :

Note : Tested with Jailbroken iPad 1 under iOS 5.1.1 from Xcode 6.3.2 under OSX Yosemite

Patch Xcode :

  • open /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk

  • change CODE_SIGNING_REQUIRED and ENTITLEMENTS_REQUIRED settings to NO and save

Config Xcode :

  • don’t code sign
  • 32 bits only (armv7)
  • SDK iOS 8.3
  • Deploy for iOS 5.1

then :

  • generate self signed certificate (code sign) from Keychain Access

  • Build project. App should be deployed to the device

  • SSH to the device

  • Grab binary (.app) and put it on your desktop

  • sign the binary with codesign as follow (in terminal) :

      export CODESIGN_ALLOCATE=${allocate}
      codesign -fs "Name" Program

where “Name” is the name of the certificate and Program is the name the Program.app (you must specify .app).

  • upload the binary back to the device where you grabed it

You should be good to go !

I will push further with more complex apps

Well ! everything seems fine now ! whatever the app !