Solution to errors installing dependencies on ubuntu

#1

So, i’ve installed Ubuntu 18.04 LTS and tried to configure the newest linux compilation of the OF, (nightly builds, of_v20190324_linux64gcc6_nightly.tar.gz)
and encountered hwe-related errors while installing dependencies:

Installing libgl1-mesa-dev-hwe-18.04
E: Unable to locate package libgl1-mesa-dev-hwe-18.04
E: Couldn't find any package by glob 'libgl1-mesa-dev-hwe-18.04'
E: Couldn't find any package by regex 'libgl1-mesa-dev-hwe-18.04'
error installing libgl1-mesa-dev-hwe-18.04
Reading package lists... Building dependency tree... Reading state information...
this seems an error with your distribution repositories but you can also
report an issue in the openFrameworks github: http://github.com/openframeworks/openFrameworks/issues
#2

Googled it up, and found this link - https://github.com/openframeworks/openFrameworks/issues/6208 - I post it here because I believe it is important to stay here in the forum should anyone encounter these issues…
According to it, you have to modify install_dependencies.sh script, find libgl1-mesa-dev${XTAG} and remove the ${XTAG} at the end of that…

Followed the hint, and it worked.