Snow Leopard - Sticky Thread

There are a couple of issues relating to Snow Leopard and openFrameworks. These issues will be properly addressed in the next OF update. But in the meantime here are some tips.

Firstly if you want to make apps which are compatible with 10.4 you should make sure to check the checkbox for 10.4 SDK when installing xcode.

If you are compiling against the 10.4 SDK when you open your project and try and compile you may see an error like this:

To fix this open up your project settings ( Project->Edit Project Settings ) and in C/C++ compiler version, change this from GCC 4.2, to GCC 4.0.


If you don’t care to have the 10.4 SDK, then you will have to set your project target to 10.5 or 10.6. If you do this then you can leave the C++ compiler on GCC 4.2. However you might see hundreds of warnings relating to string to char * conversions. These warnings will be addressed in the next release of OF. A temporary fix is to switch to the GCC 4.0 compiler (as above) and that will get rid of the warnings.

So to sum up:
SDK 10.4 + GCC 4.2 = No go
SDK 10.4 + GCC 4.0 = All good
SDK 10.5/6 + GCC 4.2 = Works, but lots of warnings
SDK 10.4/6 + GCC 4.0 = All good

When will the next update be out? This post was made in October 2009.

Check the downloads page.
We have a snow leopard friendly 0061 release out.

:smiley:

I’m having a few complaints from Quase-Cinema users running Snow Leopard (full screen 2 monitor span problem).
I’m developing on OS 10.5. To get perfect results on 10.6, can I still develop on 10.5, or should I upgrade my developing OS?

What is the specific issue?
Could it be that they don’t have “Use extended desktop” set in the Glut preferences?

Thanks Theo, it can be so. I’ll check.
The issue is that the app runs at 2048x768 (spanning 2 1024x768 monitors) fine in windowed mode, when changed to fullscreen, the second screen goes black.

Ahh interesting.

And this doesn’t happen for Leopard users?
I would check that the “Use extended desktop” setting is checked - but it could be because in 0061 we shipped OF with a custom GLUT framework so we could stop apps locking your machine when they crash in fullscreen.

The only user really trying to get this working and reporting is using Snow Leopard. I’m waiting on his feedback about the his extended desktop (it’s checked on my machine).
Another user found the error on Win XP.

On my machines it runs fine (Leopard, Win XP - and experimentally on Ubuntu as GAME_MODE).

Hi Theo,

The problem just happened on a machine of mine yesterday.
It was a Windows XP notebook, GeForce 6000 series. (Should I move this talk to another part of the forum?)

The app tuns fine on two monitors on windowed mode. When switched to full screen, the left screen is fine, but the second screen disappears, showing only the desktop.

Since I was making a presentation, I struggled to make it work. Finally it did work, changing the nVidia properties to Span, instead of TwinView. Span is not good for everyday use, since it shows the task bar on both monitors, and dialog boxes are divided between the two monitors.

Yes this is normal behavior on Windows.
Twin View presents the screens as two separate displays so the call to go fullscreen resizes the window to the first display.

Horizontal Span presents both monitors as one single display allowing OF to span across both screens.

( Horizontal Span is sort of the same as the GLUT setting on mac which allows OF to run across both displays. )

For Laser Tag I hacked some code which does a fake fullscreen on windows regardless of whether you are running horizontal span or twin view.

The code for the project is here:
http://muonics.net/blog/index.php?postid=26

T

Thanks, Theo, I’ll check out the code.

But, the project worked fine on OF 0.05 and 0.06, on TwinView…

How to proceed in Vista, that doesn’t support Span mode?

I seem to be getting this issue with the iPhone 0061 release… Does anyone else have a problem compiling?
“error: There is no SDK with the name or path ‘iphoneos2.2.1’”
I get this after changing the Base SDK to iPhone 3.2 and 4.0
OS 10.6.4 Xcode 3.2.3

Hi Duffy, I struggled with this one for a little while, despite seeming to have changed the base sdk etc under project settings to the correct iphone os, this error continues to appear- to fix it you need to double click on the OF+iphone target in the left hand navigation bar- this opens a dialogue box in which you see the offending item (iphone os 2.x.x), which when you change and try compiling again, should fix that error

that worked perfectly! Thanks!

Thanks for the help, but it seems to not work for me.

After installing xcode 3.2.3 and downloading openframeworks (10.6) when i try to run former projects (10.4) it doesn’t work either way.

When changing to 10.4 + GCC 4.0 it gives me tons of errors with the ofSoundPlayer.h (loot at screenshot).
The same with the other combinations.
Someone knows what could be the issue here?

![](http://forum.openframeworks.cc/uploads/default/885/Screen shot 2010-09-06 at 12.37.05 .png)

After trying for 3 days to get something to compile I found something that works.

System -
XCode 3.2
MacBookPro (Intel Core i5)
OS X 10.6.5
openFrameworks 0.62

  1. Reinstall complete XCode IDE with all options. I went back to 3.2 that came with my system software instead of 3.2.5 w/iOS SDK.
  2. Change Architectures in both the app example and openFrameworks Targets to ** 32-bit Universal ** from ** Native Architecture of Build Machine **

I am going to try to bring XCode back up to 3.2.5 to get the iOS SDK back but it’s working for now. Hope this helps some of you that were beating your head against your desk as I was.

T

is this still relevant? was there a new release for 10.6.6 that runs?

if helps, im using without issues:

  • osx 10.6.8
  • xcode 3.2.6
  • OF007