Snow Leopard + New XCode = OF Nightmares!

So ever since updating my mac to the latest OS and XCode, I have had nothing but issues with OF. I get TONS of deperciated warnings about string to char* (mainly from FMOD, but others too) and several libraries do not compile anymore. I didn’t install the backward support for 10.4, not knowing they were removing it, but even after going back and doing that, I get more problems.

List of libs that don’t work anymore:

Most of Memo’s Libs including: MSAFluid, ofxSimpleGuiToo, MSA3dPhysics mainly.
any FMOD libs throw tons of warnings…
I have a few more, but Im not infront of my laptop.

Also, once I installed the 10.4 base SDK again, I get a error concerning gcc 4.2 and main.cpp and nothing will compile at all, even when trying to change compiler to 4.0 it will still give the same 4.2 error.

to be clear, do you have errors or warning?

Also, are you compiling for debug or release (I suspect release will fail, since it’s trying to build ppc that’s no longer supported) ?

do the core examples in OF work?

I have a few students using 10.6 ok, after they set the compile sdk to 10.5 and compile in debug they are ok.

more information is helpful !!

take care,
zach

So to be more specific:

Set to 10.5 | Debug | i386

Mostly Warnings, in the thousands, all the same, here is one:

/Applications/of_v0.06/apps/examples/soundPlayerExample/…/…/…/libs/fmodex/inc/fmod_errors.h:29:0 /Applications/of_v0.06/apps/examples/soundPlayerExample/…/…/…/libs/fmodex/inc/fmod_errors.h:29: warning: deprecated conversion from string constant to ‘char*’

seems that most of the woes are stemming from anything that has to do with sounds, all core examples seem to be working ok, allthough I did experience an odd ofQT error that I was unable to reproduce. I got this error while trying to figure out why a lot of my MSA libs are now broke.

Anything that uses ofxSimpleGuiToo or MSAFluid is broke, I noted these errors here:

http://forum.openframeworks.cc/t/google-summer-of-code-project-for-of-interfaces/1918/0

hi psykel,

I haven’t done any testing with oF and 10.6 but ran into woes with snow leopard on a different project. Here are some suggestions that might help:

  • “clean” your project files before rebuilding. sometimes this leads to non-reproducable errors

  • also upgrade to the latest xcode (3.2). Some errors I had disappeared with this step. The 10.6 upgrade does not automatically upgrade xcode.

  • make sure you build for i386. Project that are set to current platform will build for 64bit (default on 10.6) and fail to link.

/stefan

I was actually able to correct most all of the warnings by making a small change to fmod_errors.h:

  
  
#ifdef __GNUC__   
static char *FMOD_ErrorString(FMOD_RESULT errcode) __attribute__((unused));  
#endif  
  
static char *FMOD_ErrorString(FMOD_RESULT errcode)  
  

to

  
  
#ifdef __GNUC__   
static const char *FMOD_ErrorString(FMOD_RESULT errcode) __attribute__((unused));  
#endif  
  
static const char *FMOD_ErrorString(FMOD_RESULT errcode)  
  
  

as for the MSA stuff, still trying to work that out, but that is small in comparison.

I noticed that this warning is also showing up in ofAppGlutWindow.cpp, but was not able to make the same change because of requirements in glut for the function call, and I didn’t want to change glut.h

the tons of warnings with fmod are related to newer versions of gcc, in linux was like that too, till 006 were there’s a later version of fmod. i suppose we can include the latest fmod for mac too in 0061 to solve them.

I recently upgraded to Snow Leopard/Xcode 3.2 but only today have started attempting to do any work in it.

I’m having a similar problem to the OP, running up 948 warnings all saying “Deprecated conversion from string constant ‘char*’” in fmod_errors.h. This appears to be unique to the desktop version of OF — I don’t get this with the version for iPhone, though I do get a “file is not of required architecture” warning for [of]/libs/gluIphone/libGLU.a.

(Edit: it appears that I only get the architecture error when building without a device connected, building for injection into the iPhone shows no problems.)

It’s not really causing any trouble at the moment (though it is very distracting), but I thought it was worth reporting.

Hello all,

I’m running into the similar issues so I followed all of your suggestions, including theo’s thread (http://forum.openframeworks.cc/t/snow-leopard—sticky-thread/2749/0)
however, I still can’t run even the simplest app.

Here is the steps that I followed:

  • Opened up very core example app in Xcode 3.2
  • Got this error related to 10.4 SDK and GCC 4.2
  • Went to project settings, changed Compiler Version from GCC 4.2 to GCC4.0
  • Set to Target Version 10.5/ Debug/ build for i386
  • Tried “Clean”
  • GCC4.2 error removed but got 2 new errors (pls see attached screenshot)

2 new errors and lots of char* warnings. I understand char* issue will be solved in the next version release, however can anyone suggest anything for these new errors?
They show up in every app that I try to run with this setting.

Thanks,
Akiko

![](http://forum.openframeworks.cc/uploads/default/466/Screen shot 2009-11-13 at 20.07.39.jpg)

Hey sorry about that - I didn’t have that issue but it can be easily fixed.

change:

  
long sync  

to

  
GLint sync  

Hope that works for you!
Theo

Theo,

GLint sync solved this one! Thanks so much!

Thank you Theo for pointing me in the right direction. I used your long sync fix above and that fixed 2 of the errors in the build. I got this other one as well. Does anyone know how to fix it?

Also, I dont see the other compiler version of 4.0 just 4.2?

Hi - I think this error can be fixed by changing:

  
   #ifdef TARGET_LINUX  
        // linux needs this:  
        #include <netinet/tcp.h>		/* for TCP_MAXSEG value */  
    #endif  

to

  
  
   //#ifdef TARGET_LINUX  
        // linux needs this:  
        #include <netinet/tcp.h>		/* for TCP_MAXSEG value */  
    //#endif  

in ofxUdpManager.h ( or UDPManager.h )

Theo, code you presented above doesnt exist as far as I can see within Lasertag? Or was your comment/fix something to implement in the target_Win32 location I show in the screen cap?

Thank you