Skeleton tracking without calibration (psi pose)

Hi fbrmz,

Thank you for the info. It is good to know that there is an alternative solution. Unfortunately I am limited to OS X (not sure about Sarah). I am still trying to figure out this problem at the moment. I am so out of my depth with OF and trying to install drivers etc. I am thinking should I try to do this with Processing or should I stick with OF.

Everytime I attempt to address one problem, another 10 crop up. It is hard to know whether the issue is with the OS version or the software versions…totally frustrating.!!

Anyway, thanks again for the advice.

@sarah this is the current error I am getting but honestly, I dont even know if I have the correct installation of OpenNI and NITE yet…thanks.

No such file or directory: ‘/Users/johnodwyer/Desktop/openFrameWorks/of_v0.8.4_osx_release/apps/myApps/TryingToGetOpenNIWorking/src/ofApp.cpp’


@sarah_ Hi, I’m just wondering did you have any issues installing OpenNI on your machine? It seems that we both have the same setup but when i am installing through Terminal, I am having an issue when it comes to this step. So annoying!!

I followed this tutorial:

Everything else worked fine except for step 4 part 6. I cannot progress with any work in openFrameWorks until I am sure that the installation is working correctly. I think i will follow the other tutorial to uninstall the current setup and start from a clean slate.

Sorry for being a pest and hijacking your post. Feel free to tell me to calm down!!

edit: Hi Sarah, I managed to get the right drivers and middleware working following the blogpost I linked to above. At least I am making some progress. Now I know that the kinect is properly connected and operational. It took me all day!! Tomorrow, I will attempt to run the example file from the ofxOpenNI addon by following your tips.

Thanks again.


hi john.

glad you’re making progress! i had a similar process, fixing one error caused 10 new ones to appear… it took me almost a week in total but it ended up working. (it was pretty adventurous, sometimes i would end up on japanese blogs and google translated the installation instructions. i love the internet).

we have very similar setups so don’t give up just yet! :slight_smile:

another thing that came to my mind that i forgot to mention was that you’ll need to run this script “” in the “copy_to_data_openni_path” directory once you moved its contents to the correct location (to your [example]/bin/data/openni folder) (from terminal, just cd to the directory, then run “./”)

for the “no such file or directory”-error make sure that xcode finds all the files it needs (header files, source files, libs).

  • build settings -> “header search paths” and “library search paths”
  • build phases -> “compile sources” and “link binary with libraries”

what kinect version do you have? (it has to be “kinect for xbox” and not “kinect for windows” in order to work with os x)

can you build & run the default openframeworks examples? especially the kinect example? (if yes, it shouldn’t be an OF error but maybe a linking error or a OpenNI or NITE one…?)

we should definitely share videos of our projects once we’re finished!

good luck!

Jeez at this point it almost sounds like it would’ve just been easier to run parallels or something instead to leverage native drivers. @sarah_ and @John_ you may want to forward this on to the upkeeper of ofxOpenNI since its clearly a troublesome process. If you can try to document your process we could probably create a tutorial that might help more than random internet searches which leads to foreign language blogs…

good point. since i’m a beginner i wasn’t sure if the complications were ofxOpenNI-related or just due to me being new to OF in general! :S

the last commit to ofxOpenNI was in 2012 and it says it’s deprecated? so i’m not sure who to forward this to/who to ask, (maybe @gameover)?

Right it said v1 was depreciated but looking at the experimental branch there hasn’t appeared to be updated in at least 2 years. There are a bunch of forks that have been more recently updated but its sorta like a needle in a haystack since none of them seem to be the new upkeeper and are just splinters of the original though this one seems the most recent - that sort of the problem when there are a bunch of forks that aren’t being pulled in and updated regularly

Yea, I’m coming from the same place as Sarah. Very new to OF, so it was hard to say if the problem was me or the addon! Also, I had to get familiar with Github but that’s not relevant in this thread.

Like you @sarah_ I too ended up on Japanese blogs and using Google translate. (it is at this point where I began to question my sanity!!). @DomAmato, a tutorial is certainly needed on the installation of this addon. For me, the problem is that this is the first time I used OF so probably not the best way to get introduced.

As per the title of this post, the idea is to abolish the clunky calibration pose so that we can present our installations elegantly in a public forum. Up to this point, it looks like both of us have been using Synapse which works (once calibrated with the pose). It’s good for a proof of concept stage.

Today, I will try to run the examples and see what occurs. I guess the best thing to do is keep posting on this thread until there is success. It will be of some help to somebody.

@sarah, did you manage to loose the pose?
@DomAmato the most recent fork that you linked to says it is for the OpenNI2 and NITE2 libs which put me right off attempting to use it as a lot of blog posts said these do not work on OSX without the original Microsoft SDK. That stuff is sorta beyond me right now.

Ok guys thanks for everything so far. I will post back with updates of my progress. I hope this is ok with you @sarah_ I still feel like I have hijacked your post!!

BTW: my kninect version is ‘kinect for xbox (1414)’ so at least I know that is correct!

That can’t be right about the microsoft SDK as it is only available on windows, hence the reason for libfreenect and openNI :wink: I’ll assure you using the kinect natively is much much easier but obviously you guys don’t exactly have that option.

I feel like thats pretty common that beginners end up here on the forums because they get in over their heads from being a bit overly ambitious. I was the same way when I first started but its a good way to learn too. The problem usually arises from addons that, like openNI, haven’t been maintained well or the user is no longer active so troubleshooting tends to be a bit trickier.

Some people add in a little tutorial to their work to get things calibrated and tracking when on display but yeah the poseless tracking is generally much nicer. Sorry I couldn’t be of more help I work more closely with the core of OF and notably the windows side of it.

I guess I am showing my ignorance when i mention the Microsoft SDK being relevant to the setup problems I am having. Thanks for the info either way @DomAmato and yes you are right, that is exactly how I ended up on this forum. I was lucky that I found this post as it is the most recent, relevant conversation on a subject that I needed help with. It is good to see that such an active forum exists for OF. It has been a great help to me, if even just to reassure that auto-calibration is indeed possible with my setup.

Guys, I have actually managed to get one of the demos working so right now, I am thrilled! I’m not too sure how I did it but the advice given here certainly helped. Now I need to get my brain around how to proceed. I need to spit out the right and left hand positions and send the data over OSC to my other apps.

@sarah_ I am wondering what that script does. I have not ran it yet but the demo still works??

I am really grateful for everybody’s engagement on this thread, so thanks very much.

Hey @sarah. Just stumbled across this post.

It sounds like it does almost everything that we need for our projects. I just tried to get it running but have had no luck yet.
At least I have managed to get some of the demos running from the ofxopenni addon. I think I will give this new find a go tomorrow.

Otherwise, I am over my head with all of this and I will resort back to Synapse until I figure out how to work with OF properly.



hello Sarah! I stuck on this ofxOpenNI TOO!! The compiler error is that:
ld: warning: directory not found for option ‘-L/Volumes/Macintosh HD 2/of_v0.9.0RC2_osx_release/apps/myApps/mySketch/bindata/openni/lib’
ld: library not found for -lXnDDK
clang: error: linker command failed with exit code 1 (use -v to see invocation)

But libXnDDK.dylib does exits in the /lib . I try running the scripts you mentioned but still, not work!! :persevere:
Hope you could help me find the solution :grinning:

hey ryan! are you using XCode? in your build settings / run scripts you should be able to add the library manually!
let me know if it worked!

  • build phases -> “compile sources” and “link binary with libraries”

Hello again! It seems I’ve linked all the libs. I post a snapshot of the screen. Can you see the snapshot?Do I miss something?

hello ryan!
i’m afraid i can’t help you with this one… but if it’s a linker error my guess is that it can’t find the header files – (so in “build settings” -> “header search paths”, make sure it includes all of your project’s folders that contain header files (sometimes it helps to include the folder recursively)… good luck!

I’ll go for it , thx anyway!

Was there any progress on this issue?

I am having same issue right now…

hi! yes! i ended up using ofxNI2 (which i think uses NiTE 2 though my
memory is a bit foggy)
let me know if that works for you!

I ended up using streaming way. getting data from Synapse to Openframeworks

Are you using KinectV1?

I had ofxOpenNi from gameoverhack working so I forked it and updated the fork with my changes, you can find it here

It is functioning with OSX only, but with OF 0.9.0, I changed the folder structure to make it a bit easier for myself but it is far from perfect. The biggest pain is that it will not work with the project generator until I have some more time to dedicate to this, for the moment you can duplicate the example (far from elegant but it does work).

A quick note, this hardware is very old now as is the addon, We can’t expect every contributor to keep everything working for every OF and OS update. The new kinect, which will only do skeletons on windows works really well and there is a great addon from Elliot Woods to use it in OF, there is as yet no mac solution for getting the skeleton data, but it is really worth it if you can use windows.

I hope this helps someone out.