Simple Shader-Crashing on Raspberry Pi 2

Hi

I did a slideshow using shader for effects between images, the openFrameWorks app only takes images from a directory and update the list, then count the time for transitions and sent to the my fragment and vertex shader programs…this work fine in raspberry pi B+ with arm 6… now i have a raspberry pi 2, and now my app compiled well but in running time it crashed(the screen is white for milliseconds until the aplications closed that), with this errror:

error terminating… J_MESSAJE_CODE… in think its any internal library linking,??
I use the GLES, for render,…
it is a bug??

Hey there – what version of oF are you using? Have you tried compiling with the latest version from master (0.9.0)?

Hi, I have the of_v0.8.4_linuxarmv7l_release, for more details using gdb and tracing the error until:

Program received signal SIGILL, Illegal instruction.
0x76d80608 in ?? () from /usr/lib/arm-linux-gnueabihf/libcrypto.so.1.0.0
(gdb) bt
#0  0x76d80608 in ?? () from /usr/lib/arm-linux-gnueabihf/libcrypto.so.1.0.0
Cannot access memory at address 0x0
#1  0x76d7d004 in OPENSSL_cpuid_setup () from /usr/lib/arm-linux-gnueabihf/libcrypto.so.1.0.0
#2  0x76fe8254 in ?? () from /lib/ld-linux-armhf.so.3
#3  0x7efff7f4 in ?? ()
Cannot access memory at address 0x0
#4  0x7efff7f4 in ?? ()
Cannot access memory at address 0x0
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

The new version?? v0.9 of openframeworks…
I compiled that, and I got:

/home/pi/of_v0.9.0RC1_linuxarmv7l_release/apps/myApps/slideshow2/src/main.cpp:11:74: note: candidates are:
In file included from ../../../libs/openFrameworks/ofMain.h:53:0,
                 from /home/pi/of_v0.9.0RC1_linuxarmv7l_release/apps/myApps/slideshow2/src/main.cpp:2:
../../../libs/openFrameworks/gl/ofGLProgrammableRenderer.h:22:2: note: ofGLProgrammableRenderer::ofGLProgrammableRenderer(const ofAppBaseWindow*)
  ofGLProgrammableRenderer(const ofAppBaseWindow * window);

but whats is the argument??
in tmy main.cpp I include:

#include "ofMain.h"
#include "ofApp.h"
#ifdef TARGET_OPENGLES
#include "ofGLProgrammableRenderer.h"
#endif
//========================================================================

    int main( ){
            #ifdef TARGET_OPENGLES
            //ofSetCurrentRenderer(ofGLProgrammableRenderer::TYPE); (not work)
            ofSetCurrentRenderer(ofPtr<ofBaseRenderer>(new ofGLProgrammableRenderer()));
            #endif
            ofSetupOpenGL(1920,1080, OF_WINDOW);

the code above works for openframeworks 0.84 on armv6…
I assume the problem is in the selection of the render, noticed small changes in this new version. and must be properly configured to use for rendering using shaders?