Shaders on the RPi 2

Has anyone got the ofxFX addon examples to work on the rpi2? Or is that unrealistic?

In file included from ../../../addons/ofxFX/src/ofxFX.h:35:0, from src/testApp.h:11, from src/main.cpp:2: ../../../addons/ofxFX/src/ofxFXObject.h:44:0: warning: "STRINGIFY" redefined [enabled by default] /opt/vc/include/interface/vmcs_host/vc_cec.h:36:0: note: this is the location of the previous definition In file included from ../../../addons/ofxFX/src/ofxFXObject.cpp:38:0: ../../../addons/ofxFX/src/ofxFXObject.h:44:0: warning: "STRINGIFY" redefined [enabled by default] /opt/vc/include/interface/vmcs_host/vc_cec.h:36:0: note: this is the location of the previous definition In file included from ../../../addons/ofxFX/src/ofxFX.h:35:0, from src/testApp.h:11, from src/testApp.cpp:7: ../../../addons/ofxFX/src/ofxFXObject.h:44:0: warning: "STRINGIFY" redefined [enabled by default] /opt/vc/include/interface/vmcs_host/vc_cec.h:36:0: note: this is the location of the previous definition ../../../addons/ofxFX/src/ofxFXObject.cpp: In member function ‘void ofxFXObject::selectShaderSource()’: ../../../addons/ofxFX/src/ofxFXObject.cpp:242:35: error: a function-definition is not allowed here before ‘{’ token ../../../addons/ofxFX/src/ofxFXObject.cpp:459:1: error: expected ‘}’ at end of input ../../../libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:261: recipe for target '../../../addons/obj/linuxarmv7l/Release/ofxFX/src/ofxFXObject.o' failed make[1]: *** [../../../addons/obj/linuxarmv7l/Release/ofxFX/src/ofxFXObject.o] Error 1 make[1]: *** Waiting for unfinished jobs.... make[1]: Leaving directory '/home/pi/openFrameworks/apps/addonsExamples/example-conway' ../../../libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:126: recipe for target 'Release' failed make: *** [Release] Error 2

Also I’ve been working through the Resonate 2013 rpi shader examples and the particles one doesn’t seem to draw any particles, it runs but I just get the background and no particles.