Setup qt windows make bash: make: command not found

Hello I am fallowing this setup instruction from here http://openframeworks.cc/setup/msys2/

Now I cannot fallow this step.

Open an MINGW32 shell (run C:\msys64\mingw32_shell.bat) and compile oF libraries:

cd your_oF_directory/libs/openFrameworksCompiled/project
make

In my terminal I get something like this.

$ make
bash: make: command not found

I am trying to setup openframework for qt on windows os… any help?

have you run the install_dependencies script?

Hello I tried it to run the install_dependencies script again now all instruction from http://openframeworks.cc/setup/msys2/ are successfull.

Now I am facing another issue again. from this link http://openframeworks.cc/setup/qtcreator/
Qt Creator > Preferences > Build and Run > Compilers and if it’s not there add a compiler that points to c:\msys64\mingw32\bin then in the Kits tab configure the Desktop Kit to use gcc from msys2.

What i did is like the fallowing.

Now I get error if I run the examples videoPlayerExample
I get this error
"Cannot lock build graph file /of_v0.9.8_msys2_release/examples/video/Error in “Util.asciify(“build-videoPlayerExample-Desktop-Debug”)”: TypeError: Property ‘asciify’ of object Core::Internal::UtilsJsExtension(0x29bc118)is not a function/qtc_Desktop_96935204-debug/qtc_Desktop_96935204-debug.bg’:Failed to create directory

how to fixed this?

the compilers look fine to me, usually qtcreator detects the compiler right away if msys2 is installed and you’ve run install dependencies. can you post a screenshot of the error?

here is it i try to open the example.

I am using qtcreator-3.5.1

that sounds like a bug in qtcreator, perhaps trying to remove the build cache which is usually a level below the example and from your screenshot i think should be called qtc_Desktop_96…_debug

Sorry I cannot fallow… how to called qtc_Desktop_96…debug I search the internet but I cannot find it.

What is your qt version that works on windows? I use qtcreator-3.5.1 because I read the instruction here http://openframeworks.cc/setup/qtcreator/ it use qt-3.5.1… how about you what is your qt version that runs on windows?

When qt creator compiles it creates a folder where it stores auxiliary files called qtc_Desktop… it’s usually one level below your project so if your project is in:

openframeworks/apps/myapps/myproject

the temporary folder will be in

openframeworks/apps/myapps/

try deleting it and restarting qtcreator

If you are using 0.9.8 then qtcreator 3.5.1 is the correct version, something newer might work but it’s not warantied. if you use the nightly builds or 0.10 then 4.6.0 is the latest version from qt creator and works fine with OF

now I am using qt 4.6.0 and also use the openframework from this link http://ci.openframeworks.cc/versions/nightly/of_v20180507_msys2_nightly.zip

My new problem are I cannot build the project and I cannot run… How to fixed this?

have you checked that the kits in tools > options > c/c++ are correctly setup? The instructions for the setup have been updated for the 0.10.0 release perhaps try to follow those since they worked for me yesterday fine when updating them

Can I request please create a video tutorial on how to setup openframeworks for all operating system and IDE from start to finish? I think its easy to fallow if the instruction is in videos compare to documentation. For the beginner like me I preferred video tutorial.

Just add environment variable

C:\Program Files (x86)\GnuWin32\bin

Thats All.

Cheers,
Ranjit