Setting up Qt Creator: Windows / Msys / 64bit - Missing dependencies

Hi

I’m just starting out with Open Frameworks. I’ve set up Qt Creator according to the tutorials via the docs … only problem is, when I try to build one of the examples, I’m greeted by an error:

image

Could anyone who knows, point me in the right direction?

Cheers

Luke

Okay… n00b pointer: Don’t press the big ‘|>’ button hoping it will build. It won’t! … use the menu.

Build > Build project "Your project name .."

I spoke too soon :wink:

I’m now receiving the following:

C:\oF\of_v0.11.0_msys264_release\libs\openFrameworksCompiled\project\makefileCommon\config.shared.mk:305: *** couldn’t find cairo zlib openssl glew glfw3 libcurl openal sndfile libmpg123 0 pkg-config package or it’s dependencies, did you run the latest install_dependencies.sh?. Stop.

I’ve re-run install_dependencies, and there’s nothing left to install.

  • Running 64bit on Window 10 (v. 0.11).
  • Qt Creator (v. 4.11.1).

Any help appreciated

I’ve been able to build the project via the command line (mingw64) so I think the problem must be with QT config.

I’ve tried to run pkg-config list-all and can confirm the packages listed are installed.

Hi @lukus

I am having exactly the same problem. Did you ever find a way to get around the error?

Hi @Martin_Wilson … I’m afraid not.

I realised I can compile from the command line, so have fallen back to doing that. Just using Qt as an editor.

Would be great to get qt creator working fully; imagine something’s changed in a later version, as docs reference a different menu structure.

I´m having the same issue, (Couldn’t find cairo zlib openssl glew glfw3 libcurl openal sndfile libmpg123 0 pkg-config package or it’s dependencies, did you run the latest install_dependencies.sh?. Stop) I got QT/OF working on my laptop but I cannot make it run on my desktop computer. If anyone has any suggestions they are welcome.

Hello there, I had the same issue, but now it is working for me.

While checking libs\openFrameworksCompiled\project\msys2\config.msys2.default.mk i noticed that you need to set the MINGW_PREFIX environment variable.

My environment settings for my msys2(64) kit in qt creator look like this:

MINGW_PREFIX=/mingw64
MSYSTEM=MINGW64
PATH=D:\msys64\mingw64\bin;D:\msys64\usr\bin;${PATH}