Scene-Graph addon on current OF, with vs2012 (solved)

#1

Hi,
I’m starting a project where I’ll have to use a scene-graph.

I Tried for hours to convert Soso to vs12 but it just doesn’t work…

I’ve seen ofxScene too but it was Mac only :frowning:

So I’m wondering,
did any one found a simple addon for a scene graph that works on vs 2012?
… or successfully converted Soso to vs12?

Thanks, Ludovic.

#2

I think you can use ofxScene in Windows OS, Did you create you project with the project generator? i used it with Ubuntu 12.04 64 bit without issues as i remember…

#3

I tried ofxScene but its for Mac but doesn’t work with windows :(…

At least, when I tried there was tons of missing libraries…

But im not much used to install of addons, maybe i did something wrong?
(I still installed 5-6 other addons without problems, I know the base…)

thx, Ludovic.

#4

Shouldn’t needed to link libraries as i remember (if i’m not wrong) but what kind of error do you receive?

#5

Ah maybe you need to add the ofxAssimpModelLoader addon…!

#6

I had some bad times trying to makes ofxAssimpModelLoader work on my project…
But when it finnaly worked, it pretty much solved my problem! :slight_smile:

Thanks for the help! :slight_smile:

Only videolayer doesn’t work since its ment for apple,
I changed a coupple lines of code from shader or videoPlayer and it worked fine. ^^

And btw I just now installed ofxScene and it works only with ofxAssimp, no need to patch glitches on this one! :slight_smile:

-Ludovic

#7

Happy that you solved the issue @ludovic_migneau !

Only videolayer doesn’t work since its ment for apple,

As i know OF should switch to different platform videoplayer, exactly what kind of issue did you encountered?

Can you mark as solved the topic, please? in this way we can discriminate from helpful topic to not.
Thanks!

#8

The only thing I have now is which line it breaks when running if I try to use the videoplayer.
It breaks in ofShader::begin() because shader is null but its caller (ofVideoPlayerObject::render())
didn’t see it null with (if(shader)…).

More then that, I don’t know what exactly is the bugg…

Also when I said it didn’t work because its ment for OSX I said it because there was some variables ( GLEE_ARB_shader_objects) which seemed to be for OSX… I might be mistaking.

Changing it to GL_ARB_shader_objects allowed me to compile, however, I get a runtime error…

#9

hey @ludovic_migneau,
dou you still using ofxScene ?
I compiled on OF master branch and high sierra and it works.
but i dont know if is outdate or there are other addons recommended…