Sample Playback SoundStream sounds robotic, example code

Hi,

I’ve already posted a couple of times, but without example code.

To me this seems like this should record 10 seconds of audio, and then play it back repeatedly, but something is making the sound distort.

http://chrisbarry.info/soundsteamsimple.zip

If anyone could help me see why this is happening I would be most grateful. It’s really simple code, so it should be quite clear to someone who knows why it’s happening. It sounds like it’s being pitch shifted up.

This also has been happening with examples I’ve been downloading so maybe it is a hardware issue? If someone can run this and it sounds good, then I guess we will know it’s not the code.

Thanks.

Hi,

your code is running fine on my machine. 10 sec record - and playback no pitch change…
But it crashed in the end, when I tried to escape the app.

Best,
K.

Really! What system are you running on? I’m on a macbook pro, 13" 10.6.

This is a sample of what it sounds like on my machine.

http://chrisbarry.info/audio-distortion.m4a.mp3

I think some other people are having the same problem, so maybe it’s not just me?

Any more help would be really appreciated, I spent days trying to work out what was wrong with this!

This project here sounds perfect however…

http://forum.openframeworks.cc/t/recording-and-playback-audio-from-buffers/4512/2

Hi,

it clould be the buffersize of your soundstream. Try this config, like in the examples:

  
ofSoundStreamSetup(2,2,this, sampleRate,256, 4);  

I use my internal Macbook 13’ Soundcard and it worked. But there is still the problem, that your code always crashes in the end.

Best,
K.

Hi Optician,

Running into the exact same problem atm. Everything I record sounds robotic.
Have you managed to find a solution? I ran your sample code which is giving me exactly the same robo-results. Wondering if it’s hardware related (15" MBP 2010 i7)

Thanks!