Rpi 4 / Raspbian Buster / openFrameworks

#21

I have OF up and running on my RPi 3 B using raspian Buster.

First, to install OF edit /home/pi/openFrameworks/scripts/linux/debian/install_dependencies.sh
change line 40 from:

apt-get install freeglut3-dev libasound2-dev libxmu-dev libxxf86vm-dev g++ libgl1-mesa-dev libglu1-mesa-dev libraw1394-dev libudev-dev libdrm-dev libglew-dev libopenal-dev libsndfile-dev libfreeimage-dev libcairo2-dev libfreetype6-dev libssl-dev libpulse-dev libusb-1.0-0-dev libgtk${GTK_VERSION}-dev libopencv-dev libegl1-mesa-dev libgles1-mesa-dev libgles2-mesa-dev libassimp-dev librtaudio-dev libboost-filesystem-dev libglfw3-dev  liburiparser-dev libcurl4-openssl-dev libpugixml-dev

to:

apt-get install freeglut3-dev libasound2-dev libxmu-dev libxxf86vm-dev g++ libgl1-mesa-dev libglu1-mesa-dev libraw1394-dev libudev-dev libdrm-dev libglew-dev libopenal-dev libsndfile-dev libfreeimage-dev libcairo2-dev libfreetype6-dev libssl-dev libpulse-dev libusb-1.0-0-dev libgtk${GTK_VERSION}-dev libopencv-dev libegl1-mesa-dev libglvnd-dev libassimp-dev librtaudio-dev libboost-filesystem-dev libglfw3-dev  liburiparser-dev libcurl4-openssl-dev libpugixml-dev

That allowed me to compile OF.

Then in my project config.make file I added on line 80:

PROJECT_LDFLAGS += -latomic 

I compiled and ran the polygon example!

3 Likes
Poco JSON folder missing error
#22

Great news! did you make those changes over the github master or over @eshkrab fork?
I can test here in RPI 4

#23

That is good news, but just so you know those look like the same changes I’ve made and posted to the PR.

1 Like
#24

Hi advidaronson13,
where can man find a config.make file? I am new to OF… I am facing the same problem like you.
Thanks a lot!

#25

Hi @quappefeeder , you can find MakeFile and config.cmake inside /scripts/templates folder

If you have RPI with armv6l, you should use these ones: https://github.com/openframeworks/openFrameworks/tree/master/scripts/templates/linuxarmv6l

Cheers

#26

Thanks a lot! :slight_smile:

#27

Thanks!!!

#28

Did somebody managed to run it on RPI 4 ? Thanks!