Report about examples using /bin/data files

I’ve recently setup of_v0.7.4_android_release under OSX.

As some other users have reported most of the examples using /bin/data files are not working. After running them I can’t see these files in the sdcard.

Curiously the accelerometer examples works fine, and I can see is data (verdana.ttf file) at external sd:
/mnt/sdcard/external_sd/Android/data/cc.openframeworks…

After reading some comments from Arturo I’ve tried the nightly build of_v20130418_android_release.

If i run the image example (that is not working in v0.7.4) now works, and I see its data at internal sdcard:
/mnt/sdcard/Android/data/cc.openframeworks…

If then I revert to v0.7.4 workspace and reinstall the image example now it works, so it seems it gets the data from that internal sdcard path.

I’ve also noticed that if I uninstall the accelerometer example from v0.7.4 the data folder is deleted from external sdcard, but if I uninstall any examples from the nightly build workspace their data folders are not deleted from internal sdcard.

To sum up:

  • There may be something different in v0.7.4 in the accelerometer example about how it gets the sdcard path respect the other examples

  • In the nightly build the system to get this path can make it to point to the internal sdcard, and the data folder is not properly uninstalled along the app

I hope that this info can be useful to refine next versions.

This appears to still be broken in the nightlies/develop branch on a Nexus 7, 4.2.2:

  
  
no resources found in /storage/emulated/0/Android/data/cc.openframeworks.rush/rushresources.zip  
  

The zip IS there, and contains the resources (if I extract them manually it of course runs fine)

I experienced the same problem with the resources from the bin/data folder for the examples from the 0.8.0 release.
It works only if I manually copy the files.

I finally figured out the problem why the files are not found. You have to have a SD card for your device to make recourses work properly. I think it’s some file permission issue. The program cannot extract into the onboard memory. The problem is mentioned unser “Notes” section in https://github.com/openframeworks/openFrameworks/blob/master/docs/android.md.