reinstalling opencv-problems!

Im reinstalling OP…everythings works fine but Icant install opencv library.

When I come to one of the last steps:

“e) in project options->parameters->linker

well the explorer doesnt show these files even I know that thses files are inside the mapp

funny microsoft!

Ive already installed the opnecv in another machine but using DEV c++…I did it in 20 min. max,but this V.S amazing…

:frowning: :frowning:

Anyway…any suggestion why the explorer in V.S doens want to show those files?


hi - I’m not sure, can you post a zip of your libs folder? I am happy to take a look. perhaps you are missing something? seems like it –

happy to help!

how do I upload zipfiles here on this forum? :roll:


hi you have “opencv” in the wrong place, and not completely there

it expects the opencv folder at libs/opencv
you have it at libs/openframeworks/opencv

and in libs/openframeworks/opencv it doesn’t look like you have everything we put up. take a look at your “opencv” folder vs. the one in the download.

the next iteration of addons will simplify a bit where to put stuff. in the meantime, I hope this helps…

also, check out this:
it fixes some issues with the cv addon and of 0.03+, you can just swap the code in compuerVision with this code……


doestn work,Im gonna do it again…from scrash.

one more question:

k) now, we add these link include paths, at
linker > general > additional library directories:
add this one:

this has to be done also for both: debug and release??


for the first part of step (k), ie adding the link include path, you should do it for “all releases” since that field is that same for both debug and release,

for the second part of step k, where you add the names of the libs you need like cxcore.lib, you should do it once for debug and once for release since VS does a strange thing - if you do “all releases” instead of adding it to all releases, it will clobber the lists for release and debug because the libraries they use are slightly different. this is why that field is blank when “all configs” are selected, and when you choose “release” or “debug” you can see the list.

I hope that makes sense - please let me know if that helps or you still have questions -

take care

ps there are images, in “steps_images” that can help lead you through the process…

take care!

Well Ive been reinstalling VS…many times already…

;y problem is that Icant still see thru the explorer wind, these files:
./…/libs/opencv/lib/cv.lib <<<
…/…/libs/opencv/lib/cxcore.lib" <<<

When I get inside the opencv/lib,thru V.S setting up computervision mapp. I find it empty even I know that the files are there…?

It works fine with DEVc++… but we want to use V.S—its better 4 understing the LIBS…

WE are 3 guys setting up V.S for a big O.P project but (Hello microsoft) is doing it difficult for us… :frowning:

I am happy to help

can you post a zip of everything (libs/apps and all) a screenshot of what you mean?


This is the error that I get…now…

ah - much easier to diagnose with a picture ! thanks …

you are having an issue with forward declaration - it’s a technique used to prevent recursive linking. basically, the issue is how can two class know about each other, because you want avoid:

(in obj_a.h)  
#include "obj_b.h  


(in obj_b.h)  
#include "obj_a.h"  

which would be endless including (an include is just copying the whole file, so you can’t do it a->b & b->a);

what forward declarations do is that in obj_a.h you just say “class obj_b”, you don’t inlude anything, but in the obj_a.cpp file you need to actually include the obj_b.h file. in your code, it looks like “ofCvColorImage” is missing “#include ofCvGrayscaleImage.h” and “#include ofCvFloatImage.h”

I’m not sure what version you are using of the cv code, but that was fixed – you can swap in this code:…

which be all you need to get up and running

we are fixing all the addons over the next days, so you may have been caught up with some incomplete code from the forum…


[quote author=“zach”]ah - much easier to diagnose with a picture ! thanks …


Ok Zach! i got it! work!!

That wasnt the problem…the problem was with this, Icouldn’t find where to paste them:


But I found it with my colleagues!!!
I think the notepad doesnt really lead this step…if I may help here:
It’d look better like this:

"Now…you add to that list, which is located under linker>Input>Aditional dependencies:

(copy and paste to this Window these files:

Gracias! :smiley:

ok cool - glad it’s working for you — to be clear, the errors you posted with the picture are about h files not getting included right, not about libs.

I’ll take a look at the text file, but anyway, we are changing all the instructions / system around right now to avoid problems like this. it’s alot of steps, so easy to mess something up, we are trying to simplify as best we can


1 Like