Reading Kinect data


#1

Hi,
I try to use a Kinect V2 for an application. Unfortunately the Kinect does not really work on my machine, it continuously turns on and off every 10-20 seconds. It seems that no information I could get can solve the problem.

So my idea was to record the necessary Kinect data streams, at the moment color and depth, on another machine and simply use these files to test my system. I found different possibilities so far:

  1. Record the stream with Kinect Studio what gives me xef files. Then I could play them back via Kinect Studio and check if the OpenFrameworks recognize the stream.
  2. Record oni files via OpenNI what seems to be the easier way with OpenFramworks because some addons already use it.

Does anyone have some experience with this procedure and can give me a hint?
Thanks a lot.


#2

I’ve been having the exact problem you describe! After much research online my best guess is that the Kinect V2 only works with a select few USB chipsets. I’ve bought a USB PCI card that is apparently compatible, and will let you know if it works.

Seb


#3

That would be great! It is really an annoying problem.


#4

Yeah USB Chipsets have been an issue in the past - not just for the Kinect but also for other image devices like the PT Grey cameras. The libfreenect readme states that especially ASMedia controllers are known to not work.

Edit: Here is a list with PCI Usb 3.0 controllers know to work.


#5

Thanks for the links. I now ordered a new USB controller. At the same time I could confirm that playing back a recorded file in Kinect Studio seems to work fine with OpenFrameworks, at least the Kinect2 addon example sees the playback files.


#6

Apparently it still doesn’t work even with the USB PCI card - this is the one I tried


#7

@seb_ly … as far as I know VIA USB controller seem to not work together with the Kinect V2. Have a look into this list for chipsets that work. I also found a more official version of this list here which states that “only USB3 controllers from Intel and Renesas are supported” … but I also had the Kinect v2 already working with NEC chipsets.


#8

just received my new one: DELOCK PCIe USB 3.0 4 Port NEC-Chipset and it now works fine!


#9

according to the specs, it has a Renesas chipset in it but I’ll double check.


#10

@haggi are you running windows 10?


#11

Yes.


#12

I had this issue and solved it by using zadig to control the Kinect drivers. There are some instructions here https://github.com/OpenKinect/libfreenect2#libusbk-driver