"'read' was not declared in this scope" in 9.x (unistd.h included)

Hi all,

I have a strange Problem compiling the example of addon ofxOmronD6T. When trying OF 0.84 (on a wheezy raspi) everything runs fine.
When compiling in 9.0 or 9.7 (on a jessie raspi) I get the following errors:

.../ofxOmronD6T.cpp error: 'write' was not declared in this scope
.../ofxOmronD6T.cpp error: 'read' was not declared in this scope

The repective line in code are:

    if(numWriteBytes > 0) {
	result = write(fh, pWrite, numWriteBytes);
	if(result != numWriteBytes) {
		throw ofxOmronD6TException("Could not write data");
	}
}

if(numReadBytes > 0) {
	result = read(fh, pRead, numReadBytes);
	if(result != numReadBytes) {
		std::string text = "Could not read enough data: " + to_string(result) + "/" + to_string(numReadBytes);
throw ofxOmronD6TException(text);

I also tried including unistd.h (which I think usually OF does for me) but same result.
This seems a very basic thing, that I should get to work with the new raspi/software too. Does anyone of you have an approach?

I am thankful for any hint!
oe