Raspbian stretch x oF 0.10 / audio example is not work


#1

soundPlayerFFTExample and soundPlayerExample is crashed with openframeworks 0.10.0 with clean setup raspbian stretch x raspberry pi 2(old one). it looks like something related with alsa. launching app is ok unless any play sound (ie. click to play).

by the way, I tried to play mp3 file with ofxOmxplayer addon. and works well.

I didn’t tested with raspberry pi model3+. soon I’ll post it.

HOST_OS=Linux
checking pkg-config libraries:   cairo zlib gstreamer-app-1.0 gstreamer-1.0 gstreamer-video-1.0 gstreamer-base-1.0 libudev freetype2 fontconfig sndfile openal libcurl glfw3 rtaudio gtk+-3.0 libmpg123 
with PKG_CONFIG_LIBDIR=
[notice ] ofAppEGLWindow: setupRPiNativeWindow(): screenRect: 1280x800
[notice ] ofAppEGLWindow: setupRPiNativeWindow(): windowRect: 1024x768
[notice ] ofAppEGLWindow: createSurface(): setting up EGL Display
[notice ] ofAppEGLWindow: createSurface(): EGL Display correctly set 0x1
[notice ] ofAppEGLWindow: createSurface(): no current renderer selected
[notice ] ofAppEGLWindow: createSurface(): default renderer detected
[notice ] ofAppEGLWindow: createSurface(): surface created correctly
[notice ] ofAppEGLWindow: createSurface(): API bound correctly
[notice ] ofAppEGLWindow: createSurface(): -----EGL-----
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION_MAJOR = 1
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION_MINOR = 4
[notice ] ofAppEGLWindow: createSurface(): EGL_CLIENT_APIS = OpenGL_ES OpenVG
[notice ] ofAppEGLWindow: createSurface(): EGL_VENDOR = Broadcom
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION = 1.4
[notice ] ofAppEGLWindow: createSurface(): EGL_EXTENSIONS = EGL_KHR_image EGL_KHR_image_base EGL_KHR_image_pixmap EGL_KHR_vg_parent_image EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_lock_surface 
[notice ] ofAppEGLWindow: createSurface(): GL_RENDERER = VideoCore IV HW
[notice ] ofAppEGLWindow: createSurface(): GL_VERSION  = OpenGL ES-CM 1.1
[notice ] ofAppEGLWindow: createSurface(): GL_VENDOR   = Broadcom
[notice ] ofAppEGLWindow: createSurface(): -------------
[notice ] ofAppEGLWindow: setupPeripherals(): peripheral setup complete
[notice ] ofAppEGLWindow: setupNativeUDev(): created udev object
[notice ] ofAppEGLWindow: setupMouse(): mouse_fd=5 devicePath=/dev/input/by-path/platform-20980000.usb-usb-0:1.2:1.1-event-mouse
[notice ] ofAppEGLWindow: setupMouse(): mouse device name = Lenovo ThinkPad Compact USB Keyboard with TrackPoint
[notice ] ofAppEGLWindow: mouse x axis min, max: 0, 0
[notice ] ofAppEGLWindow: mouse y axis min, max: 0, 0
[notice ] ofAppEGLWindow: setupKeyboard(): keyboard_fd=6 devicePath=/dev/input/by-path/platform-20980000.usb-usb-0:1.2:1.0-event-kbd
[notice ] ofAppEGLWindow: setupKeyboard(): keyboard device name = Lenovo ThinkPad Compact USB Keyboard with TrackPoint
[notice ] ofAppEGLWindow: setupPeripherals(): native event setup complete
Illegal instruction
/home/pi/oF/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:190: recipe for target 'run' failed
make: *** [run] Error 132

DAC HifiBerry issue (edit: or Pi Zero sound issue)
#2

hmm… stretch x oF0.10 with raspberry pi model 3+ works fine.


#3

I have a similar issue. In my case it’s Pi Zero that doesn’t work. Pi3 works fine for me also.

I posted here :

Did you ever find a solution?


#4

I have the same problem with rpi zero. Rpi 3 works fine. Does anyone have a solution to this?