Raspberry Pi - Problemes with soundPlayerExample

Hi there,
somehow, soundPlayerExample is not working with my Raspberry Pi.
Compiling works, App runs, but the sounds are not played. there are no errors in the log.

Other examples like videoGrabberExample or the addon ofxomxplayer (with sound!) are working fine.
I’m using the rca video out and the analogue audio out, memory split: 64mb

Do i have to recompile anything? I have no idea what to try next.

Thx
Oli

UPDATE: Changing from PORTAUDIO to RTAUDIO ( http://forum.openframeworks.cc/t/problem-with-audio-in-linux-portaudio/8374/0 ) didn’t help. list_devices() lists the alsa-chip

Are you on the latest RPI kernel? Note that you can’t just update by using apt-get update && apt-get upgrade.

you may have to do this

https://gist.github.com/jvcleave/4972661

Hello everyone,

I´m a beginner working in a simple installation, with 5 audio tracks playing continuos in loop. I based in the soundPlayerExample, which works fine. My problem is as I wanna work with longer clips, I can´t load all in the RAM, so I set in loadSound “true” for streaming. With small audio clips it plays, with larger clips it collapses and always comes with this warning.

Warning: Encountered more data after announced end of track (frame 1/1). Frankenstein!

Warning: Real sample count differs from given gapless sample count. Frankenstein stream?

Warning: Encountered more data after announced end of track (frame 1/1). Frankenstein!

Warning: Real sample count differs from given gapless sample count. Frankenstein stream?

Any ideas? Thanks in advance

Hi,

I’m having the same problem. Fresh install of OpenFrameworks on RPI 3 and the sound examples always complains about ofSoundUpdate() not implemented on this platform.

Any ideas?