Raspberry Pi camera board + OF

install gcc:
sudo apt-get install gcc-4.7 (there is 4.8,4.9 too but i think you want seven) I would google to make sure.
check version:
sudo gcc --version

again the commands are right but do some googling i forget if you need to remove the old gcc first. good luck.

currently the Pi2 has Raspbian 4.8.2 installed.
strange, because all other openframework example work just fine.
but i guess i will give 4.7 a try.

hmmmm…

Have you setup for a camera at raps-config?

wow thanks.
that did the trick.

for the records, i did not change the gcc. i just enabled the camera as per your last link.

i also had to command out this line ofSetCurrentRenderer(ofGLProgrammableRenderer::TYPE);
thanks again.

Hi guys.
When I finish using @jvcleave 's raspi camera sample,Terminal don’t show my command. Do you know how to fix this problem?

@jvcleave
I really appreciate your raspi camera works.

A year and a bit later…

I’m using the @jvcleave’s ofxRPiCameraVideoGrabber and noticing the vertical sync artifacts that @vade initially mentioned.

I looked at the master and develop branches, but master is more recent by about a year.

I also tried Jason’s recommended settings for /boot/config.txt to force 720p and hdmi boost active; as Jason said, this improves the artifacts (I still see some sync lines but much less), but the app is now less performant; where as previously (with the RPi’s default 1080p mode) i was getting about 60fps, now i get about 27fps.

is this to be expected?