Raspberry Pi 2 Setup Guide (0.8.4)

Hello. I’m following the instructions from the guide but now I’m getting an error while compiling. This hasn’t happened before, I’ve installed OF on many Pi 2s. Only recently this started happening. Am I missing something?

Here’s the error that comes in at the end of running the ‘make’ command on Step 11 above:

makefileCommon/compile.core.mk:228: recipe for target ‘…/…/…/libs/openFrameworksCompiled/lib/linuxarmv7l/obj/Release/libs/openFrameworks/app/ofAppEGLWindow.o’ failed
make[2]: *** […/…/…/libs/openFrameworksCompiled/lib/linuxarmv7l/obj/Release/libs/openFrameworks/app/ofAppEGLWindow.o] Error 1
make[2]: *** Waiting for unfinished jobs…
makefileCommon/compile.core.mk:199: recipe for target ‘Release’ failed
make[1]: *** [Release] Error 2
make[1]: Leaving directory ‘/home/pi/of_v0.8.4_linuxarmv7l_release/libs/openFrameworksCompiled/project’
…/…/…/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:126: recipe for target ‘Release’ failed
make: *** [Release] Error 2

Okay. Nevermind everyone. I saw on the main OF Pi setup page that the version has been updated from 0.8.4 to 0.9.0.

http://openframeworks.cc/setup/raspberrypi/Raspberry-Pi-Getting-Started.html

So the above steps should be updated in case anyone is using them. Thanks.

hey, Im facing issues on stage 8. for some reason everytime i try curling it i get this:

curl performs SSL certificate verification by default, using a “bundle”
of Certificate Authority (CA) public keys (CA certs). If the default
bundle file isn’t adequate, you can specify an alternate file
using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
the bundle, the certificate verification probably failed due to a
problem with the certificate (it might be expired, or the name might
not match the domain name in the URL).
If you’d like to turn off curl’s verification of the certificate, use
the -k (or --insecure) option.

anyone have a hint on why?
have tried cleaning up the sd twice and running all the procedure again. no luck.
RPi 2

thanks

Thanks for the guide!
It worked very nice, I compiled the 3dPrimitiveExample with success, but after doing the updates :

apt-get update
apt-get upgrade
rpi-update

now is not working.
I am getting this error at the end and some others too:

makefileCommon/compile.core.mk:239: recipe for target '/home/pi/of_v0.9.0_linuxarmv7l_release/libs/openFrameworksCompiled/lib/linuxarmv7l/obj/Release/libs/openFrameworks/gl/ofBufferObject.o' failed
make[2]: *** [/home/pi/of_v0.9.0_linuxarmv7l_release/libs/openFrameworksCompiled/lib/linuxarmv7l/obj/Release/libs/openFrameworks/gl/ofBufferObject.o] Error 1
make[2]: *** wait: No child processes.  Stop.
makefileCommon/compile.core.mk:205: recipe for target 'Release' failed
make[1]: *** [Release] Error 2
make[1]: Leaving directory '/home/pi/of_v0.9.0_linuxarmv7l_release/libs/openFrameworksCompiled/project'
/home/pi/of_v0.9.0_linuxarmv7l_release/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:126: recipe for target 'Release' failed
make: *** [Release] Error 2

I tried to delete the OF folder and decompress again the tar, but is not working…

Well, sorry, I don’t know why, but after a ‘make clean’ it’s working.
Sometimes I need to use ‘sudo make’ and sometimes it works just with ‘make’ without ‘sudo’… I think that was the above problem…

Now my only doubt it’s if It’s working the multi cpu / threading. I added the lines to ‘/etc/environment’ like it’s suggested above, but, during compiling, on the htop window I don’t see all the cores working together; just one of the it’s at 100% and the others are generally unused…

EDIT: ok, now I can see the full activity on all 4 cores when compiling.
I am using the fresh 0.9.1. I don’t know if the persistence on ‘profile’ file it’s working…
I have to use ‘sudo make -j4 PLATFORM_VARIANT=raspberry2 run’
I also noticed that the step 8 it not required on 0.9.1, correct me if I am wrong.
I am not sure, but maybe some examples are getting errors…

getting error in 9 step as it says “error install_depencies.sh” cannot make the exmple in 11 step

Hi, Is there an updated guide for Openframeworks 0.9.0 or newer versions on RPI 2?

tks

Pippo

See the rpi setup guide on the main site.

This is the error i am facing while running make command … everything went well but i dont know how to clear it . Advance thanks

…/…/…/libs/openFrameworks/sound/ofRtAudioSoundStream.cpp:1:0: error: target CPU does not support ARM mode
#include “ofRtAudioSoundStream.h”
^
makefileCommon/compile.core.mk:228: recipe for target ‘…/…/…/libs/openFrameworksCompiled/lib/linuxarmv7l/obj/Release/libs/openFrameworks/sound/ofRtAudioSoundStream.o’ failed
make[2]: *** […/…/…/libs/openFrameworksCompiled/lib/linuxarmv7l/obj/Release/libs/openFrameworks/sound/ofRtAudioSoundStream.o] Error 1
makefileCommon/compile.core.mk:199: recipe for target ‘Release’ failed
make[1]: *** [Release] Error 2
make[1]: Leaving directory ‘/home/pi/of_v0.8.4_linuxarmv7l_release/libs/openFrameworksCompiled/project’
…/…/…/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:126: recipe for target ‘Release’ failed
make: *** [Release] Error 2

For those who need to run 0.8.4 on a Raspberry Pi 2 or 3 for any reason (an incompatible plugin for instance) on recent Raspberrian system, here is a summary of some of the above posts:

  1. download open frameworks 0.8.4 for linux arm7 and unpack
  2. remove the string "python-argparse " from ~/of_v0.8.4_linuxarmv7l_release/scripts/linux/debian/install_dependencies.sh
  3. install the dependencies
    cd ~/of_v0.8.4_linuxarmv7l_release/scripts/linux/debian/ sudo ./install_dependencies.sh
  4. download the rpi2 config file
    cd ~ curl https://raw.githubusercontent.com/openframeworks/openFrameworks/master/libs/openFrameworksCompiled/project/linuxarmv7l/config.linuxarmv7l.default.mk -o of_v0.8.4_linuxarmv7l_release/libs/openFrameworksCompiled/project/linuxarmv7l/config.linuxarmv7l.rpi2.mk
    edit this new config.linuxarmv7l.rpi2.mk file:
    pico of_v0.8.4_linuxarmv7l_release/libs/openFrameworksCompiled/project/linuxarmv7l/config.linuxarmv7l.rpi2.mk
    and change the line
    PLATFORM_CFLAGS += -march=armv7
    to
    PLATFORM_CFLAGS += -march=armv7-a
  5. Setting the environmental variables
    export MAKEFLAGS=-j4 PLATFORM_VARIANT=rpi2 pico ~/.profile
    add this line
    export MAKEFLAGS=-j4 PLATFORM_VARIANT=rpi2
  6. On my system I couldn’t compile open frameworks just yet… If needed, download and install the latest version of OF, e.g. 0.9.3
    Unpack and install the dependencies, for instance:
    cd ~/of_v0.9.3_linuxarmv6l_release/scripts/linux/debian/ sudo ./install_dependencies.sh
  7. Now I could compile 0.8.4 applications. I hope you too :slightly_smiling:
1 Like

Can someone please mention the steps to install openframeworks on a raspberry pi 2 model b? I have tried almost all the different pages on the internet and the compilation fails. Please help.

the RPI2 process is the same but there is a current issue with Raspbian packages that you may be running into:

https://github.com/openframeworks/openFrameworks/issues/5395

I am able to compile with no output during make run for the examples in the folder 3D