Raspberry pi 2 + kinect


#21

Hey @gepatto ,

Maybe a clean install will be the trick. On the same page as you with everything else, but no luck for me.


#22

Make a backup of your sd-card! (Or buy a new one)
I installed the latest version of raspbian (november), and then only samba (for easy network access to my files from my laptop, cause I still don’t like any of the text-editors on the raspberry ) and OFv0.9.0

That worked for me. No other tricks involved.
(Edit) I do have my kinect connected via a powered usb hub!


#23

Hi @danielJay - did this work out for you? I have a clean install of Raspian Jessie and 0.9.0 and the same troubles as you: kinect detected, but no data.


#24

I have the same(?) issue: clean install of Jessie on a RaspberryPi3 with of 0.9.3. I’m runnig it with sudo and a powered usb hub. The kinect is found at first but then somehow lost:

[verbose] ofxKinect: context inited
[verbose] ofxKinect: 1 device found
[verbose] ofxKinect: id: 0 serial: A00365A09745107A
send_cmd: Input control transfer failed (18)
freenect_fetch_zero_plane_info: send_cmd read 18 bytes (expected 322)
freenect_camera_init(): Failed to fetch zero plane info for device
[ error ] ofxKinect: could not open device A00365A09745107A
[warning] ofxKinect: update(): device -1 isn’t delivering data, reconnecting tries: 1
Failed to open camera subdevice or it is not disabled.Failed to open motor subddevice or it is not disabled.Failed to open audio subdevice or it is not disabled.[ error ] ofxKinect: could not open device -1
[warning] ofxKinect: update(): device -1 isn’t delivering data, reconnecting tries: 2
[warning] ofxKinect: no available devices found
[warning] ofxKinect: update(): device -1 isn’t delivering data, reconnecting tries: 3
Could not claim interface on motor: -6

Has anybody any ideas?


#25

I was having the same issue, while trying to run the ofxKinect example on a RPI 3, Raspbian Jessie, OF 0.9.3. Then I found this at the ofxKinect Github page:

Also, you can add a set of udev rules which allow you to run a Kinect app without root privileges:

sudo cp libs/libfreenect/platform/linux/udev/51-kinect.rules /etc/udev/rules.d

After that, it worked like a charm :slight_smile: . Turns out it was a permission problem.


#26

Hello to all,

I am experiencing the same problem with the ofxKinect example called “kinectExample” ( Kinect v1, RPi 3, Raspbian Jessie, OF 0.9.3 armv6 (is it a problem?)) .

When I type lsub, it looks like my RPi recognises the kinect:

Bus 001 Device 004: ID 046d:c534 Logitech, Inc. 
Bus 001 Device 020: ID 045e:02ae Microsoft Corp. Xbox NUI Camera
Bus 001 Device 026: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 001 Device 016: ID 045e:02c2 Microsoft Corp. 

I have updated the permission rules like @medul_la suggested, but I still get this error :

[verbose] ofxKinect: 1 device found
[verbose] ofxKinect:     id: 0 serial: 0000000000000000
Could not open audio: -4
Failed to open motor subddevice or it is not disabled.Failed to open audio subdevice or it is not disabled.[ error ] ofxKinect: could not open device 0
[warning] ofxKinect: update(): device -1 isn't delivering data, reconnecting tries: 1 

I have followed the instructions on that website that shows a basic example using python and opencv, and I was able to get some data from the Kinect.

One last thing (and sorry for the really stupid question),
you mentioned the importance of having a powered usb hub for the kinect, are we talking about that?

Any insights?


#27

Hi @carolinebuttet,

In my case it was not necessary to have the Kinect connected to a powered USB hub, but you might give it a try. The picture you have sent shows the Kinect power supply, which is not the same thing. These specific USB hubs are powered by an external source, and not by the USB connection, such as below:

You should also check what kind of power supply you are using with your Rasp. I was using a 5v - 2.2a power supply, and it worked very well, had no trouble while connecting the Kinect directly to the Rasp. I was even able to use a couple of USB extensions of about 1.5m each, with not too much trouble.

Sometimes the application took a couple of trials to access the Kinect data, and I guess that is due to the low voltage of the Rasp, but after a few seconds, it would start correctly.


#28

Quick update:
I finally fixed the issue that is documented in this topic .
Basically, because I am using a kinect 1473 and not 1414, I had to disable the audio build in the libfreenect header file (see topic).

And voilà, working like a charm!
Thanks to @medul_la and the others.


#29

i´ve tryed all above solutions and is not working for me.

Using : v0.9.8_linuxarmv6l_release
2017-02-06 jessie distro

Can someone point me out in wich version you got it working?


#30

On jessie with of_v0.9.8_linuxarmv6l_release this finally worked for me:
raspberry pi3 libfreenect Bugfix https://github.com/OpenKinect/libfreenect/commit/88166014859c09f6ad6a93f0862bdcc4e46dc87e,

linked from here: https://raspberrypi.stackexchange.com/questions/74655/erratic-errors-in-libfreenect-on-raspberry-pi-3