Raspberry pi 2 + kinect

Ok so it does find the kinect,
This may sound strange but have you tried a different USB port or connect without your usb-hub.
And try with the original ofxKinect-addon again.

i try almost everything, format and reinstall everything from zero but I still get the same error, I am using optimal voltage and amperage (5V, 2A - 5A), the SD card is Class 4, it can affect?

I never use class-4, only class-10

But I really don’t know if that could be the cause.
I have tried my kinect ( also a 1414) on 2 sd-cards that have of-0.8.4 on them and they both work with my test.

So I’m not sure what is going on unfortunately.

i try everything. and i have de same problem, change the sd card, change the power supplies.
I do not know what is happening u.u

my kinect not init in raspberry pi 2, someone knows something ? I’m desperate :c

A few things to try:

  • It doesn’t seem clear whether you’ve confirmed that the RPI is able to see the Kinect device – Have you confirmed that the device is visible with lsusb?
  • If you can see the device, have you confirmed that another piece of software can connect to the kinect? If it can’t then it’s likely a hardware problem.
  • Have you tried using a different USB plug? Are you plugging in directly to the RPI?

Other ideas …

  • Have you tried to use the latest version of OF?
  • Have you tried changing the gpu / cpu memory distribution?

I try everything of this, but dont work anyway. I’ll try to get a new camera to test kinect.
thanks for your help!

hello
i test a two new kinect cameras (1414 model) and have the same problem.

[verbose] ofxKinect: context inited
[verbose] ofxKinect: 1 device found
Failed to open camera subdevice or it is not disabled.Failed to open motor subddevice or it is not disabled.Failed to open audio subdevice or it is not disabled.[ error ] ofxKinect: could not open device -1

u.u

I am having similar mentioned issues in this thread with the KinectExample.

I didnt use the PG to compile the kinectExample in 0.9.0, but copied the OS X kinectExample over to RPi2 since the make files are compiled.

No errors during compiling. Something in detecting Kinect. I have used the libfreenect Python wrappers without any issues, so this isn’t a hardware issue ( for me).

EDIT:
had tried all suggestions from @bakercp & @gepatto

EDIT #2
on Rasbian Jessie Nov 2015 release

I have upgraded to of 0.9.0 and raspbian jessie (clean install).
And it worked straight away for me with my xbox kinect model 1414
So I think it must somehow be related to the kinect device or the power-supply.
for me lsusb returns these vendor an product ids

Bus 001 Device 014: ID 045e:02ae Microsoft Corp. Xbox NUI Camera
Bus 001 Device 012: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
Bus 001 Device 013: ID 045e:02ad Microsoft Corp. Xbox NUI Audio

how about yours?

Hey @gepatto ,

Maybe a clean install will be the trick. On the same page as you with everything else, but no luck for me.

Make a backup of your sd-card! (Or buy a new one)
I installed the latest version of raspbian (november), and then only samba (for easy network access to my files from my laptop, cause I still don’t like any of the text-editors on the raspberry ) and OFv0.9.0

That worked for me. No other tricks involved.
(Edit) I do have my kinect connected via a powered usb hub!

Hi @danielJay - did this work out for you? I have a clean install of Raspian Jessie and 0.9.0 and the same troubles as you: kinect detected, but no data.

I have the same(?) issue: clean install of Jessie on a RaspberryPi3 with of 0.9.3. I’m runnig it with sudo and a powered usb hub. The kinect is found at first but then somehow lost:

[verbose] ofxKinect: context inited
[verbose] ofxKinect: 1 device found
[verbose] ofxKinect: id: 0 serial: A00365A09745107A
send_cmd: Input control transfer failed (18)
freenect_fetch_zero_plane_info: send_cmd read 18 bytes (expected 322)
freenect_camera_init(): Failed to fetch zero plane info for device
[ error ] ofxKinect: could not open device A00365A09745107A
[warning] ofxKinect: update(): device -1 isn’t delivering data, reconnecting tries: 1
Failed to open camera subdevice or it is not disabled.Failed to open motor subddevice or it is not disabled.Failed to open audio subdevice or it is not disabled.[ error ] ofxKinect: could not open device -1
[warning] ofxKinect: update(): device -1 isn’t delivering data, reconnecting tries: 2
[warning] ofxKinect: no available devices found
[warning] ofxKinect: update(): device -1 isn’t delivering data, reconnecting tries: 3
Could not claim interface on motor: -6

Has anybody any ideas?

I was having the same issue, while trying to run the ofxKinect example on a RPI 3, Raspbian Jessie, OF 0.9.3. Then I found this at the ofxKinect Github page:

Also, you can add a set of udev rules which allow you to run a Kinect app without root privileges:

sudo cp libs/libfreenect/platform/linux/udev/51-kinect.rules /etc/udev/rules.d

After that, it worked like a charm :slight_smile: . Turns out it was a permission problem.

1 Like

Hello to all,

I am experiencing the same problem with the ofxKinect example called “kinectExample” ( Kinect v1, RPi 3, Raspbian Jessie, OF 0.9.3 armv6 (is it a problem?)) .

When I type lsub, it looks like my RPi recognises the kinect:

Bus 001 Device 004: ID 046d:c534 Logitech, Inc. 
Bus 001 Device 020: ID 045e:02ae Microsoft Corp. Xbox NUI Camera
Bus 001 Device 026: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 001 Device 016: ID 045e:02c2 Microsoft Corp. 

I have updated the permission rules like @mateusk suggested, but I still get this error :

[verbose] ofxKinect: 1 device found
[verbose] ofxKinect:     id: 0 serial: 0000000000000000
Could not open audio: -4
Failed to open motor subddevice or it is not disabled.Failed to open audio subdevice or it is not disabled.[ error ] ofxKinect: could not open device 0
[warning] ofxKinect: update(): device -1 isn't delivering data, reconnecting tries: 1 

I have followed the instructions on that website that shows a basic example using python and opencv, and I was able to get some data from the Kinect.

One last thing (and sorry for the really stupid question),
you mentioned the importance of having a powered usb hub for the kinect, are we talking about that?

Any insights?

Hi @carolinebuttet,

In my case it was not necessary to have the Kinect connected to a powered USB hub, but you might give it a try. The picture you have sent shows the Kinect power supply, which is not the same thing. These specific USB hubs are powered by an external source, and not by the USB connection, such as below:

You should also check what kind of power supply you are using with your Rasp. I was using a 5v - 2.2a power supply, and it worked very well, had no trouble while connecting the Kinect directly to the Rasp. I was even able to use a couple of USB extensions of about 1.5m each, with not too much trouble.

Sometimes the application took a couple of trials to access the Kinect data, and I guess that is due to the low voltage of the Rasp, but after a few seconds, it would start correctly.

Quick update:
I finally fixed the issue that is documented in this topic .
Basically, because I am using a kinect 1473 and not 1414, I had to disable the audio build in the libfreenect header file (see topic).

And voilà, working like a charm!
Thanks to @mateusk and the others.

i´ve tryed all above solutions and is not working for me.

Using : v0.9.8_linuxarmv6l_release
2017-02-06 jessie distro

Can someone point me out in wich version you got it working?

On jessie with of_v0.9.8_linuxarmv6l_release this finally worked for me:
raspberry pi3 libfreenect Bugfix https://github.com/OpenKinect/libfreenect/commit/88166014859c09f6ad6a93f0862bdcc4e46dc87e,

linked from here: https://raspberrypi.stackexchange.com/questions/74655/erratic-errors-in-libfreenect-on-raspberry-pi-3