Raspberry Pi 2 install failing

I’m trying to get Openframeworks installed on the new Raspberry Pi 2 but it is failing to even start the compile as it reports there are missing packages. I’ve tried both the Raspberry Pi install and the generic arm7 and neither work.

I’ve installed it on my old Pi without problem, I’ve followed all the steps in the same way.

Anybody manage to get this working yet?

What is failing, specifically ? I ordered one and will test when received.

I have been trying. I managed to install the packages manually… sorry I didn’t make I note of what I was doing.

After this, I am down to the error of:

ofVideoGrabber.cpp:1:0: error: target CPU does not support ARM mode

Full transcript here. This is with the Armv7 download of OF.

the way we detect that a board is a raspberry relies slightly on the cpu type and once we detect it’s a rpi we include the arm6 libs by default so the new one having arm7 will surely fail. we’ll need to do some changes to the makefiles to detect the correct architecture.


Thanks for that. I can’t even get past the first stage. I get:

checking pkg-config libraries:   cairo zlib gstreamer-app-1.0 gstreamer-1.0 gstreamer-video-1.0 gstreamer-base-1.0 libudev freetype2 fontconfig sndfile openal openssl libpulse-simple alsa gtk+-3.0 libmpg123 glesv1_cm glesv2 egl 
makefileCommon/config.shared.mk:260: *** couldn't find some pkg-config packages, did you run the latest install_dependencies.sh?.  Stop.

The install_dependencies script didn’t fail with any kind of error. I won’t spent any more time on this now I know there are obstacles ahead right now.

Many thanks.

Hi there, I’m happy to work on this, but don’t yet have a RPI 2 …

1 Like

Just got ours in today. Before I get lost down a rabbit hole, would the linux arm7 install work on Snappy Ubuntu Core?

If the compiler detects that it’s running on a rpi like arturo says then I would think not.

I could spend sometime on this, if it would help. But I’d need some hints of where to start… is possible to get some hints on where changes in the makefile system these changes may need to happen. I have had a look through…

Hey all, I put my instructions for starting to fix this in the issue here:


I don’t have an RPI2 yet, but was quite involved with the original RPI makefile creation so I’m excited to help vicariously until I get my own PI.

Give it a shot if you like!


I’ve tried your suggestions @bakercp and I get the same problem as @rc1

../../../libs/openFrameworks/video/ofVideoGrabber.cpp:1:0: error: target CPU does not support ARM mode
makefileCommon/compile.core.mk:228: recipe for target '../../../libs/openFrameworksCompiled/lib/linuxarmv7l/obj/Debug/libs/openFrameworks/video/ofVideoGrabber.o' failed

@bakercp yay! Your suggestions work with 0.8.4 and with the addition of changing the architecture to armv7-a.

@Cuthbert here is a temporary branch of 0.8.4 with the modification if you want to try it.

Doing this on the latest from github throws the error:

error: ‘shared_ptr’ is already declared in this scope
error: ‘weak_ptr’ is already declared in this scope
error: ‘enable_shared_from_this’ is already declared in this scope

which seems to be a current unrelated issue.

Thanks! It’s quite a bit faster at compiling.


I’m excited to try it once I get one of these … !

Thanks @rc1 for the change to the config file. It all works for me now too.

I hardly had enough time to make a cup of tea while it compiled.

The RPi2 is going to be a lovely platform to run OF on.


Thanks for this Post. My RPi2 works too. :smile:

1 Like

The updated build file was merged into the master branch today and will be included in the next release. Thanks for all of the testing!


is there a way to install ofX on a rpi2 right now?
I tried to compile it but always getting:

 *** This package doesn't support your platform, probably you downloaded the wrong package?.  Stop.

But i also can’t find an armv7l folder to try the manual fixing.

Which openFrameworks release are you running on your Raspberry Pi 2?

This one. I just followed the getting stated instructions.


Since the raspberry Pi 2 is an Armv7 device (the raspberry pi 1 was an armv6 device), you’ll need to start with the Armv7 distribution. The website hasn’t been updated for the raspberry pi 2 yet. Then you’ll need to follow the rest of the instructions in this thread.