Raspberry OS 64

Hello

Long history i need to use some aarch64 libs so i loaded raspbian 64 in my rpi…

I tried with of armv7 and armv6 and was able to compile and run examples but framerate is low for example on polygonExample (± 36fps).

I tried with fake and full kms driver and different amounts of gpu memory, no diference.

main change i did on the mk files was to edit -march, tried with amrv8-a and native

Also tried with various aarch64 os and all had the same result

Anyone is using a aarch64 OS in the raspberry?

This should help ( see the end of the post ):

Thank you @theo i will try tomorrow disabling AA and post results

Also found this, that looks interesting

disabling AA did the trick!

Hi @pandereto,

I too am trying to install OF on a Pi4 with the Pi OS 64 beta, but I haven’t been able to get OF to install. I’ve tried fiddling with the armv7 and armv6 distributions but both give me all sort of errors even when changing the .mk files.

Do you still have your make files?

Hi

No, sorry i dont have the files…