Raspberry 3 Video4Linux

I have installed Jessie-Lite and OF on a RPI 3
I am using SSH but with an HDMI monitor and camera connected to the Pi.
The simple OF examples work, raspi-still works.
However when I try any example that uses the videoGrabber in OF it fails because it cannot find video4linux when it enumerates udev

I have tried installing uv4l but no luck. Anyone have any idea on getting v4l working on the `rpi 3? I have Googled but the discussions are all a few years old.
Maybe I have to install the full Jessie.

~/openFrameworks/examples/video/videoGrabberExample $ bin/videoGrabberExample
[notice ] ofAppEGLWindow: setupRPiNativeWindow(): screenRect: 1920x1080
[notice ] ofAppEGLWindow: setupRPiNativeWindow(): windowRect: 1024x768
[notice ] ofAppEGLWindow: createSurface(): setting up EGL Display
[notice ] ofAppEGLWindow: createSurface(): EGL Display correctly set 0x1
[notice ] ofAppEGLWindow: createSurface(): no current renderer selected
[notice ] ofAppEGLWindow: createSurface(): default renderer detected
[notice ] ofAppEGLWindow: createSurface(): surface created correctly
[notice ] ofAppEGLWindow: createSurface(): API bound correctly
[notice ] ofAppEGLWindow: createSurface(): -----EGL-----
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION_MAJOR = 1
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION_MINOR = 4
[notice ] ofAppEGLWindow: createSurface(): EGL_CLIENT_APIS = OpenGL_ES OpenVG
[notice ] ofAppEGLWindow: createSurface(): EGL_VENDOR = Broadcom
[notice ] ofAppEGLWindow: createSurface(): EGL_VERSION = 1.4
[notice ] ofAppEGLWindow: createSurface(): EGL_EXTENSIONS = EGL_KHR_image EGL_KHR_image_base EGL_KHR_image_pixmap EGL_KHR_vg_parent_image EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_lock_surface
[notice ] ofAppEGLWindow: createSurface(): GL_RENDERER = VideoCore IV HW
[notice ] ofAppEGLWindow: createSurface(): GL_VERSION = OpenGL ES-CM 1.1
[notice ] ofAppEGLWindow: createSurface(): GL_VENDOR = Broadcom
[notice ] ofAppEGLWindow: createSurface(): -------------
[notice ] ofAppEGLWindow: setupPeripherals(): peripheral setup complete
[notice ] ofAppEGLWindow: setupNativeUDev(): created udev object
[notice ] ofAppEGLWindow: setupMouse(): unabled to find mouse
[ error ] ofAppEGLWindow: setupMouse(): did not open mouse
[ error ] ofAppEGLWindow: setupMouse(): did not open mouse, mouse_fd < 0
[warning] ofAppEGLWindow: setupKeyboard(): unabled to find keyboard
[ error ] ofAppEGLWindow: setupKeyboard(): did not open keyboard
[ error ] ofAppEGLWindow: setupKeyboard(): did not open keyboard, keyboard_fd < 0
[notice ] ofAppEGLWindow: setupPeripherals(): native event setup complete
[notice ] ofGstVideoGrabber: Probing devices with udev…
==== Looking for video4linux but not finding it
[warning] ofGstVideoGrabber: setDeviceID(): selected device doesn’t exist, selecting device 0
[ error ] ofGstVideoGrabber: initGrabber(): no devices found, exiting without initializing
[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded

So I tried installing the full Jessie, but it is still the same problem. ofGstVideoGrabber does not find the video4Linux driver. So I guess OF just does not work with the Raspberry camera at the moment.

OK, I’ve got it. OF does not support the RPI camera on its own, but the RPiCameraVideoGrabber project does . https://github.com/jvcleave/ofxRPiCameraVideoGrabber .
Thanks Jason, Great work!