"A signed resource has been added, modified or deleted."

  
Error from debugger: the program being debugged is not being run.  

the only time i’ve seen that is when i’m trying to launch a Distribution build with an Ad-Hoc provisioning profile (rather than a Debug or Release). since SDK 3.something if you try to launch a Distribution app remotely (ie from XCode on your dev machine) the iphone will refuse incoming connections to the app, it’s a security thing i think. Release and Debug should still be fine.

I’ve been installing only Debug apps.

BTW, some news… the problem seems to have fixed itself. I am now able to install OF apps onto my development iPod without issue.

Obviously I am pleased about this, but that I still don’t know the nature of the problem irks me significantly… if I run into it again while trying to get back into working on this game, I am liable to go on a rampage!

I’ve actually figured out why my projects break. OMFG! It seems that XCode severely dislikes me creating physical folders inside my projects. That really bothers my directory OCD (lol) because I like having my source files physically sorted in the same way that they are inside the project. But it works perfectly if I just create files from within XCode and then let them breed with each other in the project root dir.

Now that I actually know how to make XCode throw a mardy strop, might someone be able to shed light on the issue? At the very least I know what to avoid now!

wow that image is great !! we should all make drawings next to our compiler errors :wink:

I’d go with that. Also, I discovered within an hour of posting that that my deduction was incorrect. So the only real option I could see was to totally wipe my hard drive and reinstall everything from scratch. Which I did. Now openFrameworks is broken :lol:

I really can’t be arsed with doing much more towards it right now, so I’ll give it another go later or tomorrow and post up the errors I get if it breaks again.

Okay I fixed that using a Memo fix. Then I got this.

You betcha. Right. Fuck it. I guess I’ll have to do this the ridiculously hard, Apple-approved way. Fuck you Satan suck my cock, hello Cocoa I’m here to rock.

For what it’s worth I got the “a signed resource has been added modified or deleted” when overwriting all the app icon and startup images with my own images. @zach s method of running a simple ‘clean’ worked for me in that instance.