"A signed resource has been added, modified or deleted."

I’ve been getting this error popup (when trying to install an app on iPhone) with an OF project for the last few days after being forced to reinstall Snow Leopard and Xcode, and no changes I made would fix it. In frustration just now I tried creating an [official] Cocoa Touch navigation project, granting it the same App ID, and building. It worked perfectly right away.

Because the error message is so utterly cryptic and opaque, I have no idea what the problem actually is, but observation suggests that the latest versions of iPhone OS/Xcode don’t like openFrameworks (I had no problems with Leopard/XCode 3.0). I could be wrong. This is hardly an ideal situation as I’m not talented enough to do anything worthwhile without OF :stuck_out_tongue: but as long as I can get on with some CT-based paid work, I can manage for the moment.

Has anyone else experienced this, or can anyone offer an explanation as to why installing OF apps to my development iPod is so broken?

thats pretty weird sounding. have you tried installing the basic example apps after following the instructions here: http://www.openframeworks.cc/setup/iphone ?
I use snow leopard and ofxiphone and everything runs ok… :confused:

hey, have you tried this:

http://debounce.org/

(the top entry in google when searching for that error message)

or

http://mattgornick.posterous.com/xcode–…-ded-modifi

(the 2nd piece of advice about cleaning is always a good one to try in any kind of problem)

I already tried cleaning the project and it doesn’t make a difference. I also tried creating a new project from your Xcode OF template memo (this-one) and I still got that error.

In frustration this afternoon I tried re-downloading ofxiPhone and replacing the version I have now, and I now get this error instead of a successful build. Brilliant.

  
/Users/Aneurin/OF iPhone/apps/anny/test/../../../addons/ofxiPhone/src/iPhoneSoundStream.mm:74:0 /Users/Aneurin/OF iPhone/apps/anny/test/../../../addons/ofxiPhone/src/iPhoneSoundStream.mm:74: error: 'class ofBaseApp' has no member named 'error'  

I think I’ll give up forever and become a farmer instead.

I’ve seen this problem from time to time (in older xcode / non SL) and I either try

a) cleaning and building all as described here:

  1. Xcode > Build > ‘Clean’ and then ‘Clean All Targets’
  2. Xcode > Build > ‘Build and Go’

b) I trash the whole built app in the finder to be sure.

c) I rename the target / copy the xcode project to a new folder

d) unplug, replug in the phone / device I’m testing on.

I don’t know what causes the error (it seems to be something timing related to the cycle of building and debugging) but I’ve never gotten that stuck with it to the point of reinstalling xcode. after some combination of the above steps it seems to be fine.

hope that helps –
zach

That worked for me before, but irritatingly I could only install a single build each time I connected my iPod — meaning I had to disconnect and reconnect it every. single. time I wanted to change any code.

It’s kind of moot at the moment because my ofxiPhone addon appears to be broken, though I’m sure that problem is my fault somehow!

curious – I never had it happen so often – just every once and a while…

I’m sorry for the trouble. to be sure, a fresh download of ofxIphone doesn’t compile for you (the examples that come with it)?

take care,
zach

Hey, if you get the latest ofxiPhone from svn, you may need the latest openframeworks from SVN too.

I have had problems with specific app ids in the info.plist (e.g. com.msavisuals.Meshmerizer) in that while installing the app on the iphone, things can go wrong in the connect and then you are buggered for that appid for good. You need to do a hardreset if you want to reinstall an app with that id. Maybe in your case this isn’t the problem (since you tried the same app id in a new project and it worked), but i Just thought i’d mention it for the achives.

Where is the repository for OF iPhone? I can’t see a link on the downloads page.

http://code.google.com/p/ofxiphone/

has there been a fix to this?

I just tried to revisit my ofxiPhone project after upgrading to snow leopard, and it was a complete mess. I ended up having to re-check out the trunks of both oF and ofxiphone and after relinking everything including the core frameworks (CoreGraphics + OpenGLES was especially annoying), i got the following:

  
'class ofBaseApp' has no member named 'error'  

I am in total deadlock and any help will be much much appreciated.

[quote author=“zach_gage”]http://code.google.com/p/ofxiphone/[/quote]

I meant the OF iPhone repository, not ofxiPhone. (i.e. the actual framework, not the addon; to my knowledge there are significant differences between the two like the lack of poco on iPhone.)

I’m having that error too, as posted earlier, but I have updated only ofxiPhone, not OF itself. From where did you checkout OF?

the OF used for OF Iphone is regular openframeworks (same as with desktop releases). you can find SVN info here:

http://wiki.openframeworks.cc/index.php?title=Svn

take care,
zach

Oh, my mistake then. Thanks.

I’ve checked out OF from the SVN repository, but I still get that error:

  
'class ofBaseApp' has no member named 'error'  

:?

I just took a look at this. It’s actually a correct error. I’m not sure what happened here, but ofxiphoneSoundStream tries to call a function that doesnt exist in ofBaseApp.

If you add the line:

  
virtual void error(int err){}  

to ofBaseApp.h

that should solve the error

hey, i Dunno how that version of ofxiphoneSoundStream.mm got on the SVN! I just committed my ofxiphoneSoundStream.mm which doesn’t have that, so if you get latest you shouldn’t need to hack ofBaseApp

Got that back from SVN and you’re right I no longer get an error. I can compile and install successfully now. But I’ve gained a truckload of other problems. First, I continued to get the “signed resource” error, so decided to delete the project completely (it was barely started anyway) and create a new one in its place… but the successfully installed app on the iPod wouldn’t autostart, and Xcode gave me the following error:

  
Error from debugger: the program being debugged is not being run.  

The app would run perfectly fine if I started it manually, but it wouldn’t push output to the debugger, so that was kind of pointless.

Decided I must have screwed something up again, so wiped that project and started a second new one, and set everything up carefully. Then I got the fucking “signed resource” error. With an unpopulated template.

What could the problem be? It’s hard to tell with an unbelievably cryptic error message that no bastard in Apple will explain. Nobody on the entire planet has any idea what it actually means. But I tried changing Base SDK in the target’s build settings from iPhone Device 3.1.2 to iPhone Device 3.0, and suddenly the app compiled with no warnings and no “signed resource” messages.

Then I changed a script and got the “signed resource” message again.

Honestly, this whole thing is turning into a very real clusterfuck for me. It’s wrong, it’s utterly broken, and it’s fucking infuriating. I’m beginning to wish I hadn’t bothered in the first place. Not very constructive, but how am I supposed to fix an error when the error message offers no clue whatsoever as to the nature of the problem? It’s like I’m a doctor, and a patient tells me he’s ill but refuses to elaborate as to the nature of his illness. Xcode is a retard.

Pardon my French. At least I didn’t say cunt.

wow, I’m sorry it’s so rough ! iphone dev is like that some times.

some thoughts:

a) can you rename the project / target, does that help? try to be sure you have good characters (no + or spaces or paratheses in the project name)

b) if you change targets does it help

c) if you do clean, clean all targets, build and go does it help

d) if you toggle the Code Signing Identity->Any iPhone OS Device to iPhone Developer does it help

I think some combination of these above will get you there. I remember having this also a ton with bad file names (a)

take care,
zach

hi

I think this article will help you to resolve the problem…
try this out…

http://www.iphonedeveloperlabs.com/2009-…-indows-pc/