QuickTime/QuickTime.h: file not found


#1

Hi,

I just start to learn “of” two days ago on OSX using Xcode. I built the examples successfully but the compilation failed today after I update my XCode to v.8. It reports that “QuickTime/QuickTime.h: file not found” and “QTKit/QTKit.h: file not found” for some #include sentences. I googled it and found the similar problem in openCV. It seems like it is caused by OS 10.12. But my OS version is 10.11.6. However, the base SDK in Xcode 8 is OS10.12.

I am quite struggling with this because I am try to use of to finish my homework. I am trying to reinstall the previous version Xcode. But anyone has any idea for this problem in Xcode 8? Thanks!


#2

can you try removing from the openFrameworks xcode project the files video/ofQt*


#3

here’s a description of a work around :

here’s a zipped version of the 10.11 sdk:

https://dl.dropboxusercontent.com/u/92337283/OF/MacOSX10.11.sdk.zip

and a screenshot of where the sdks live inside your xcode:


#4

No, It doesn’t work. It reports No such file error.


#5

It works. Thank you!


#6

It worked with me.
But actualy I don’t have Sierra yet, but today the mac did an update and I got this problem also
Thanks


#7

same issue here without Sierra,

but solution works, thanks!


#8

@arturo your suggestion worked for me.


#9

@zach You saved me! Thanks!


#10

Thanks this solution works great for XCode 8. Does anyone have an idea of how to solve it for QtCreator as we are trying to use it for cross platform teaching ?


#11

Both solutions worked for me. But installing the 10.11 sdk into Xcode 8, also fixed compilation with Makefile.


#12

Hi all - we have a 0.9.4 Release Candidate out.
This should fix the Quicktime linking errors.

If you are able to please give it a try and post feedback in this thread.

Thanks!!
Theo


#13

Hi, unfortunately the solution didn’t work for me. I am using of_v0.8.4_osx on Xcode 8.2. OS version 10.12.4 Sierra. I need to use this version because of the ofxTesseract add-on I wanna use. I am getting another error now.
Lexical or Preprocessor Issue
** ‘openssl/opensslconf.h’ file not found**

Any lead how I could fix this? Thanks a lot.


#14

i’m using of 0.8.4 too and adding
USER_HEADER_SEARCH_PATHS = “$(OF_PATH)/libs/openssl/include”
in the line after LIB_OPENSSL2 line, on “CoreOF.xconfig” file solved the openssl issue to me.


#15

Hi Zach
I started to work with Hap Player and it asks the quicktime.h. Can we have the link to the MacOSX10.11.sdk.zip? Best
Ah never mind I just found it