QtCreator v4.3.1 qbs problem

Hello.
I have just installed new QtCreator v 4.3.1 on Ubuntu 16.04 and all my projects stops parsing.
Qt Creator complains:

/media/data/software/of_v0.9.8_linux64_release/libs/openFrameworksCompiled/project/qtcreator/modules/of/helpers.js:5 Cannot open ‘/media/data/software/of_v0.9.8_linux64_release/libs/openFrameworksCompiled/project/qtcreator/modules/of/qbs’.
/media/data/software/of_v0.9.8_linux64_release/apps/myApps/Test/Test.qbs:11: Warning: Product ‘Test’ had errors and was disabled.

OF 0.9.8 only supports officially qtcreator 4.1.0 as explained in the setup instructions

Thanks for reply. I thought that it also supports qtcreator 4.1.0 and version above. But it make sense.

The nightly builds support up until the latest 4.2.x and might support 4.3.x but haven’t tested yet

I found this Qbs reference.
So I changed helpers.js from

var Process = loadExtension(“qbs.Process”);
var File = loadExtension(“qbs.File”);
var TextFile = loadExtension(“qbs.TextFile”);
var Environment = loadExtension(“qbs.Environment”);
var qbUtils = loadExtension(“qbs”);

to

var Process = require(“qbs.Process”);
var File = require(“qbs.File”);
var TextFile = require(“qbs.TextFile”);
var Environment = require(“qbs.Environment”);
// var qbUtils = loadExtension(“qbs”);

then examples could be built. But I checked only a few examples .