qtCreator project building and compiling error

Hi,
I’ve installed OF 0.9.3 on Ubuntu 16.04 and Qt Creator 4.0.1 Based on Qt 5.6.1.
I can compile examples from command line
cd OF/examples/graphics/polygonExample
make
But if I’ve tried to make and compile a project in Qt Creator I’ve got a lot of error messages:
http://pastebin.com/a62gZgy6
You may see at the end of this youtube screenplay

https://www.youtube.com/watch?v=S63Lfap3WHc

Please help me in solving this issue
Dan

I made an OF project with QT creator.

  1. building in Qt Creator gives a lot of error
  2. it can be compiled from console without any problem
    https://www.youtube.com/watch?v=C8GttXBAzWE

How can I do it from Qt? Any help?

Looks like the QT project didn’t link to the boost libraries. Try to add -lboost_sysyem to the linker flags in 01.qbs

Thank you for your answer, I’ve tried
of.linkerFlags: ['-lboost_system'] // flags passed to the linker
but without success.
I have installed libboost-dev
this is thelocate boost_system

/home/bkb/programok/OF/libs/boost/lib/emscripten/libboost_system.a
/usr/lib/i386-linux-gnu/libboost_system.so.1.58.0
/usr/lib/x86_64-linux-gnu/libboost_system.a
/usr/lib/x86_64-linux-gnu/libboost_system.so
/usr/lib/x86_64-linux-gnu/libboost_system.so.1.58.0

That is odd. The linker flags are being parsed? Does it give you an error if you add a bogus library? Something like “-lblahblah”

Hi underdoeg!

I’ve tried of.linkerFlags: ['-lboost_syssssstem'] and it gives this error
:-1: error: cannot find -lboost_syssssstem

In projects -> Build steps I configured to build with make an it works but qbs build fails.
This is what happens:
https://www.youtube.com/watch?v=WLMxgivnfSE

Some peaple had success in linking boost libraries in *.pro files, but OF projects does not have pro files. I have no idea how to pass this issue.
Best wishes:
Dan

can you post the full compiler output? you can find it in the bottom tabs in 4 Compiler Output. You shouldn’t need to include any library since the qbs project files already include them. my suspicion is that you might have somehow more than one version of boost installed in your system and it’s probably compiling against one and linking against another

also clean the project or rebuild it so the compiler output contains all the compiler flags too and not only the linker

Thank You arturo!
Here You are the full output.
1.I’ve removed and reinstalled qtCreator
2. install_dependencies.sh – All packages were installed correctly (inclusive libboost-filesystem-dev)
3. I’ve generated a project 01 with projectGenerator
4. qtCreator build fails with these error messages:
http://pastebin.com/0yk09R33

I attach a screenshot from libboost search in Synaptic

This is the output for locate boost_system

/home/bkb/programok/OF/libs/boost/lib/emscripten/libboost_system.a
/usr/lib/libboost_system.so
/usr/lib/x86_64-linux-gnu/libboost_system.a
/usr/lib/x86_64-linux-gnu/libboost_system.so
/usr/lib/x86_64-linux-gnu/libboost_system.so.1.58.0

looking at the output of your program it seems everything is failing not only boost, every library symbol looks undefined, gl, glew, poco, freeimage…

not sure what’s going on but it’s not related to boost but to you whole config somehow.

are you using OF 0.9.3 from the web? that version doens’t usually even work with qtcreator 4 only 3.6.1 but the error is usually different, it won’t even allow you to open the project. did you modified the project files in some way?

Hi arturo!

Thank You! openFrameworks is working nice in qtCreator 3.6.1.
The problem was I’ve tried the latest version (qtCreator 4) but the build menu wasn’t enable so I’ve commented line 19 ofApp.qbs cpp.includePaths:
// cpp.includePaths.concat(Helpers.listDirsRecursive(project.sourceDirectory + ‘/src’))
This causes the errors

Now it works very nice I am happy wit it!

Best wishes:
Dan