qtCreator 4.6.0 and 4.6.1 do not show the files

Hello, I have successfully installed the last OF release on different platforms in the last week. Today I wanted to install it also on a linux(ubuntu) laptop, and it did not worked. I have done the same things as usual, I have downloaded the last release, run the install script, the compile script and the install template., but i receive this message, with the folders containing the source code disabled.

I have tried different things, like downloading qt 4.6.0 (i was on qt 4.6.1), and I have created a project from qt, or imported an example, but the result is the same.

Any Idea?

Maybe it’s something else, but did you click Projects > Configure?

Yes I did it, I always add the “force probes” flag. There is a warning near the qt version, maybe that one is the error?

Also, one of the warning is the good and old: “/examples/math/noise1dExample/noise1dExample.qbs:11: warning: Profile ‘qtc_Desktop_b8ae33ee’ does not exist.”

Following the tip that @bakercp was giving to me in this post

I was able to fix the problem.

rm -rf ~/.config/QtProject

And then run the install_template.sh script again

1 Like

I am having the same issue as described above. openFrameworks is greyed out on the QT interface and the project won’t build through QT. I am working on a dual core intel NUC with ubuntu 16.04 with gcc 5.4 installed. I have successfully installed OF 0.10.0 gcc 5 and the empty example is compiling through CL. I have tried the following combinations. In each case I also ran rm -rf ~/.config/QtProject and re-ran ./install_template.sh and tried changing the ‘force probes’ option.

  • I tried OF 0.10.0 gcc5 with QTCreator 4.6.1 and 4.5.0

  • I tried OF Nightly build with gcc5 with QTCreator 4.6.1 and 4.5.0

  • I updated gcc to 7.4 and ubuntu to 18.04 and used OF 0.10.0 with gcc6 with QT 4.6.1 and 4.5.0

None of the above worked and the next move I can think of will be to just develop it without an ide or revert back to an older version of OF and QTcreator. Any thoughts of other strategies I might try? :sweat_smile:

did you try to

  • delete the qbs.user in your project directory
  • clear the cache : ccache --clear if you enabled ccache

does it work if you open an old project ?

@bidul Thanks for your earlier suggestions, I tried opening an older project from both QTCreator 4.5.0 and 4.6.1 and this actual yielded some new errors and the files on the left no longer appear at all.

I also tried deleting ‘qbs.user’ , but this also yielded no results. When I opened the project again it asked me to configure with desktop kit and the same greyed out files appeared.

I am not sure what you mean by ccache --clear Is that something I would perhaps set in project configuration?

Apologies for responding to a deleted post. I just already tried all of it before seeing you deleted it!

when you delete the qbs.user file, qtcreator ask you to reconfigure your project since the configuration options are in this file. sorry it was a bad suggestion (that’s why i deleted the post).

i also had the errors you show us in the first picture and resolved it by reverting to the 0.9.8 qbs file

you may have a look at this thread :

This is a problem with the project generator in 0.10, can you try creating the project using the qtcreator wizard instead of the project generator?

You need to install the qtcreator wizard as explained in the setup guide and then just go in qtcreator to file > new select the openframeworks section and use create new openframeworks project

Thank you @arturo and @bidul for the suggestions! I tried reverting back to qbs 0.9.8 files while still using OF 0.10.0 and while this gets rid of the "Unexpected token ‘%’ errors openFrameworks and the project name is still greyed out.

@arturo I have been using the qtcreator wizard for all the above tests. I’ve made a quick screen capture of the process incase that might contain any relevant info. For both tests I ran rm -rf ~/.config/QtProject and re-ran ./install_template.sh

after generating the project with the wizard can you go into projects, in the buttons column on the left, and see if you still need to configure the project?

sometimes qtcreator needs to configure the project but goes directly to the edit screen which is pretty confusing.

i think this works better with qtcreator 4.7 and is compatible with OF 0.10

Also we’ve solved the issues with the PG in the next release which is already in the nightly builds

1 Like

I checked the projects tab and this is what I saw.

I changed the build directory to be the project file rather than the duplicate qtcreator creates and tried to create a new configuration, but this didn’t have any effect. What are the steps to properly configure the project?

I’ll go ahead and test things out with qt 4.7 and the PG in the nightly build.

you shouldn’t need the PG but 4.7 might solve this issue. not sure why you are getting this. it should work right away

this is what i get with qtcreator 4.7 (but was working fine for me with 4.6 as well):

If 4.7 doens’t solve the issue perhaps post a screenshot of the settings you have in Tools >Options > Build & Run > Kits

Also in the bottom in problems you have 6 messages in your previous video which will have more information about what’s failing

I moved to 4.7 and it didn’t solve the problem. This is what it looks like in the location you described.

I have a new theory that the fact that I didn’t install the codecs might be a problem. It is throwing an error that libmpg123.pc is missing and I understand that is installed with the install codecs script. I have run the codecs scripts and am currently recompiling OF. (It takes a while on this computer) It also says there is an error on line 8 of openFrameworks.qbs

yes that’s definitely a problem with a missing package nothing related to OF or qtcreator. it is installed when running install_codecs.sh perhaps double check that running that script didn’t fail

also you don’t really need to precompile OF, qtcreator will compile it the first time if it’s not compiled yet

If libmpg is installed, running: pkg-config libmpg123 --libs in the console should return -lmpg123

Ok. Problem solved. I installed the codecs and then used the qtcreator wizard without an issue.

Thanks for your time and attention on this.