Qt Creator under Ubuntu 16.04

hello !

I am using Ubuntu 16.04 which comes with Qt Creator 3.5.1
I am using the lastest oF nightly build

I ran install_dependencies.sh ands codecs

I can’t open the project, QtCreator keeps complaining that “import qbs not found” in myProject.qbs

Does Qt and openFrameworks work in 16.04 ?

PS : I built projectGenerator. PG Gui keeps complaining that projectGenerator is missing. I had to create a project from projectGenerator command line. Though i am trying to use QtCreator so i am using Qt for now… but just to keep you informed…

Thanks a lot


this may not help you because I am not using the projectGenerator but I am on Ubuntu 16.04 and happy with openFrameworks and QtCreator since years. I always setup a project like this:

  1. Copy (empty) example or old project
  2. Copy Makefile and config.make from scripts/templates/linux64 to project folder
  3. (optional) change OF path in config.make
  4. (optional) add addons.make file with used addons, one per line
  5. Go to Qt Creator > New Project > Import Project > Import Existing Project > Chose the project folder > confirm the rest
  6. Set executable under Projects > Run > Executable (usually I have to put projectName_debug in there) and set Working directory to %{buildDir}/bin

  • code completion: QtCreator should have created a file called projectName.includes, add the include paths of OF (example )
  • multiple core compilation: Projects > Build > Build steps > Details > Make arguments > set it to -j7 or whatever
  • release instead of debug version: Projects > Build > Build steps > Details > Make arguments > add Release and don’t forget to change the executable (remove the _debug)

Last note: I am currently using QtCreator 3.6.0 (I always download it from their page, seems to be better in debugging)

1 Like


thanks for the help ! but no luck here…

I tried to create a project from scratch or update one from QtCreator but it keeps throwing the same error.

in the very top of the .qbs file there is :

import qbs
import qbs.Process
import qbs.File

this is where the errror lays

try downloading qt creator from their web. latest oficial OF is tested with 3.6 and master or the nightlies work with 4.0

i am using the nightlies and installed qtcreator 4.0 from Qt web site

creating a new project from qtcreator now leads me to another error (in the .qbs file) :

oF093n/libs/openFrameworksCompiled/project/qtcreator/ofApp.qbs:19: erreur : RangeError: Maximum call stack size exceeded.

do i need to re-install oF or re-compile it ?

mmh that’s strange that should be solved in the nightlies, are you using the latest?

i downloaded it 2 days ago

yeah that should be fine. i’ll check if there’s some difference with latest master, there might be a problem with the nightlies

ok. I will see if a clean install changes anything

problem is reported line 19 on the .qbs file :

cpp.includePaths: of.cpp.includePaths.concat(Helpers.listDirsRecursive(project.sourceDirectory + '/src'))

1 Like

can you try getting alll the qbs files (all are in the same folder) from github?

you mean from the template directory ?

same problem with clean install

it works with qtcreator 3.6.1 downloaded from Qt website

though i cannot build my app which contains an external addon (ofxBox2d) : file (box2d header) not found
i created a new project using Qt template and added the ofxBox2d addon manually into the qbs file.

Building some oF example projects is ok

Same issue for me.
Is going back to 3.6.1 the only option so far?

Never mind
I’ve found this one