Qt Creator not working

Thank you so much Staffan ! I deeply appreciate it.
Yes, I can open the examples, build and run them from the terminal!
But not in QT, as it does not load the entire folder…

I do not have another computer but it was running fine in ubuntu 21… it hasn’t worked every since I installed 22…
I wonder why…

I’m still trying and thinking of solutions but I haven’t found one yet…
At worst, I will work directly from the folder but it would be nicer to have a good IDE…
Do you know another good IDE for working with oF on linux ?
I’m thinking of atom or visual studio.
I saw a couple of posts in the forum about it…

Sorry no… I’ve only used QT Creator. And I am pretty new to oF.

Someone more experienced than me will have to help here…

Hmm, just saw this. In a terminal:

export QT_DEBUG_PLUGINS=1

then start QT Creator from the same terminal.

It should tell you if any plugins fail to load! (Source: I can't open qtcreator in ubuntu | Qt Forum)

Ok, a friend of mine helped me and got it working by installing the gtk±3.0 package

3 Likes

Ok, so after making QT work on my computer, it’s not working on my new laptop :sweat_smile:
I installed Pop!_OS 22.04 and the install_template.sh script is not working at all.
Has anyone encountered this ?

Hey did you sudo ./install_template.sh? With mint, the Qt template script didn’t seem to install the templates when run as sudo.

Hi, thank you. I just ran ./install_template.sh without sudo and there is still nothing.

The script for Qt templates doesn’t output anything to the terminal when it runs. But there hopefully should be some OF options when creating a new project when you run Qt. Mint 21 is out now so I’ll put it on an old laptop this week and see how that goes with OF and Qt.

1 Like

Hi, yes, my issue is that the OF options do not appear in QT after the installation.

Hey @WillpowerStudios I goofed around with this a bit today. I was able to install and compile the nightly on Mint 21. I installed Qt Creator 6.0.2, and the script installed the OF template for it. To use OF with Qt Creator I had to do 2 or 3 more things:

  1. (re)install libgtk-3-dev and recompile OF; do this just once
  2. add the ‘-std=c++17’ flag in the .qbs file for each project that is created or imported (say from the /examples folder); do this for every project
  3. the projects in the /examples folder work in Qt Creator when they’re “imported”, rather than “opened”

So I would say to try installing Qt Creator 6.0.2 and see if you can get that one to work. In the past I’ve had to fish thru the various Qt Creator releases to find one that works well with a given linux release.

As a final note, I have the newest LMDE on another laptop and everything just installs, compiles, and runs great with no goofing around.

OK hope this helps! I know you’ve had a lot of struggles getting this all to work on ubuntu 22.04.

Hi, thanks for your input !
I installed version 6.0.2. and there is one improvement: when choosing to create a new project, the oF templates are there !
The challenge now is that only the .qbs file shows inside the folder while the src folder and the other files are missing.
When I run it, it returns this error:
! Fatal qbs error: The qbs process failed to start.
I will keep trying things… Have you seen this error before ?

fatal-qbs-error

  1. I installed the ligbtk-3-dev library
  2. how do I add the ‘-std=c++17’ ? this may be my issue…
  3. yes, absolutely !

Hey glad the Qt templates showed up this time. Hooray!

Ugh no I haven’t seen that one yet. Not sure about how to solve that or what it means.

I had to recompile OF after reinstalling libgtk-3-dev

The OF nightly build will compile with c++17 by default. Flags can be added to the .qbs file for all kinds of stuff (like linking external libs). Multiple flags are separated by commas (I think) inside the brackets, and each flag is contained in its own set of single quote marks. I changed (approximately) line 30 to:

of.cxxFlags: ['-std=c++17']
1 Like

I may have to search for another way to create my art…
I really love oF and wish it worked…
I’ll keep trying different things… Maybe a future release will consider all these new changes in Ubuntu…
I really appreciate your help on this, thank you !

If it helps, I try to wait quite a while after the 1st release of anything before upgrading. Installing a newly upgraded os can be problematic, regardless of platform or device. Sometimes it just takes a while for things to shake out, for the early adopters to post problems and fixes online. It can take a while and quite a bit of effort for things like OF to catch up. And new hardware can further complicate. The RPi4 and OF are a nice example of this.

If you get super frustrated, maybe try LMDE 5 or one of the debian-based distros, just to see. Plus its kinda fun to try out new distros.

hi Tim,
thanks for your suggestions ! a friend just helped me fix audio (input and output) and addons issues for running projects from the terminal. I can at least do my work from there. but yes, I will look into LMDE 5 or debian.
I can’t do video capture work because we can’t get gstreamer to work.
I will keep digging and trying different ideas. Thanks a lot.

When I try to open it in qt, I experience the same problem …
But vscode works great.

1 Like

Hi @scherbakov.al , you can start a new thread if you like, and maybe elaborate a bit more on what is happening, and also which linux distro you are using.

1 Like

good to know if works great on vscode, thanks :slight_smile:
on ubuntu ?

Ok, I wrote here:
Installation experience on ubuntu 22.04 and vscode

Yes, on ubuntu 22.04. While it works) but I have not yet climbed into the deep jungle of programming …

1 Like

Ok, thanks.